Talk:USB host

From Openmoko

(Difference between revisions)
Jump to: navigation, search
m (Talk:Neo 1973 USB host moved to Talk:USB host: With rare exception, the contents of this page refer to all Neos, so we remove 1973. Furthermore, since the only product is Neo, there is no need to state that either.)

Revision as of 05:46, 27 August 2008

I picked up one of these cables to try:

http://www.cablestogo.com/product.asp?cat_id=1510&sku=28107

I hooked up a USB A female-female adapter to the data/power end and to a dual PS/2 to USB keyboard/mouse adapter with a TypeMatrix 2020 keyboard on it.

I hooked the aux power line to my laptop.

While it worked, eventually the battery drained to deep discharge (I had WiFi enabled and GSM/BT/BPS disabled - Power Management was disabled).

When I looked at the power info on the Freerunner when it was still in normal USB mode, I found that the Aux line only supplies 100mA (charger_type file) and the chgmode file says "play-only".

Also, the directory for the charge info is /sys/devices/platform/s3c2440-i2c/i2c-adapter/i2c-0/0-0073/ on the Freerunner and it appears the setting for fast charge mode is simply "fast" on the Freerunner instead of "fast_cccv" (at least that's what shows up in the chgmode file when hooked up USB).

--Techiem2 23:08, 24 July 2008

Personal tools

I picked up one of these cables to try:

http://www.cablestogo.com/product.asp?cat_id=1510&sku=28107

I hooked up a USB A female-female adapter to the data/power end and to a dual PS/2 to USB keyboard/mouse adapter with a TypeMatrix 2020 keyboard on it.

I hooked the aux power line to my laptop.

While it worked, eventually the battery drained to deep discharge (I had WiFi enabled and GSM/BT/BPS disabled - Power Management was disabled).

When I looked at the power info on the Freerunner when it was still in normal USB mode, I found that the Aux line only supplies 100mA (charger_type file) and the chgmode file says "play-only".

Also, the directory for the charge info is /sys/devices/platform/s3c2440-i2c/i2c-adapter/i2c-0/0-0073/ on the Freerunner and it appears the setting for fast charge mode is simply "fast" on the Freerunner instead of "fast_cccv" (at least that's what shows up in the chgmode file when hooked up USB).

--Techiem2 23:08, 24 July 2008