Talk:Mac OS X

From Openmoko

Revision as of 19:23, 25 August 2007 by Historybuff (Talk | contribs)

Jump to: navigation, search

Comments on AJZaurus USB

First, thanks for all the hard work, it got my Neo happy and booting.

Some comments:

  • some indication when the "refresh" button is pushed that it's doing something. (Checking, downloading, etc)
  • what the status means. (F seems to mean "flashed". C means Downloaded?)
  • maybe some sanity checking? (Making sure the rootfs and kernel and uBoot aren't incompatible?)

Historybuff 19:46, 4 August 2007 (CEST)

I think that hns addressed at least the first two features in version 0.5.3. Now the GUI shows 'Cached and Flashed'. --Dcorking 16:49, 23 August 2007 (CEST)

Why AJZaurusUSB?

Q: MacOS X does work perfectly fine without AJZaurusUSB. It supports USB-Net. What do i need AJZaurusUSB for? --Deep-Thought 18:26, 16 August 2007 (CEST)

A: You might have deleted the Apple CDC drivers from your system. They interfere with the RNDIS/Ethernet Gadget. 17:57, 19 August 2007

AJZaurusUSB - everchanging Ethernet interface issue

NOTE: it appears that after each reboot of the OpenMoko you get a new interface on the Mac (this is under investigation).[1] I am experiencing the same behaviour. Cayco

I too have the ever-changing Ethernet interface issue. Historybuff 19:46, 4 August 2007 (CEST)
Each time i plug the device in, i get a new device. But traffic on the mailing list suggest this will be fixed with static mac-addresses. --Deep-Thought 18:26, 16 August 2007 (CEST)
Has been solved in 0.5.3 17:57, 19 August 2007
My usbnet has showed up first as en3, and another time as en4, but it is not ever-changing. I am using 0.5.3. No doubt there is something strange in Darwin internals, but I can live with it. --Dcorking 16:49, 23 August 2007 (CEST)
I can confirm that the update mostly solves this. I think if you flip it into dfu mode, and then come back, you still get a changed ethernet interface number. But it's not changing on each plug in anymore. Historybuff 20:23, 25 August 2007 (CEST)
Personal tools

Comments on AJZaurus USB

First, thanks for all the hard work, it got my Neo happy and booting.

Some comments:

  • some indication when the "refresh" button is pushed that it's doing something. (Checking, downloading, etc)
  • what the status means. (F seems to mean "flashed". C means Downloaded?)
  • maybe some sanity checking? (Making sure the rootfs and kernel and uBoot aren't incompatible?)

Historybuff 19:46, 4 August 2007 (CEST)

I think that hns addressed at least the first two features in version 0.5.3. Now the GUI shows 'Cached and Flashed'. --Dcorking 16:49, 23 August 2007 (CEST)

Why AJZaurusUSB?

Q: MacOS X does work perfectly fine without AJZaurusUSB. It supports USB-Net. What do i need AJZaurusUSB for? --Deep-Thought 18:26, 16 August 2007 (CEST)

A: You might have deleted the Apple CDC drivers from your system. They interfere with the RNDIS/Ethernet Gadget. 17:57, 19 August 2007

AJZaurusUSB - everchanging Ethernet interface issue

NOTE: it appears that after each reboot of the OpenMoko you get a new interface on the Mac (this is under investigation).[1] I am experiencing the same behaviour. Cayco

I too have the ever-changing Ethernet interface issue. Historybuff 19:46, 4 August 2007 (CEST)
Each time i plug the device in, i get a new device. But traffic on the mailing list suggest this will be fixed with static mac-addresses. --Deep-Thought 18:26, 16 August 2007 (CEST)
Has been solved in 0.5.3 17:57, 19 August 2007
My usbnet has showed up first as en3, and another time as en4, but it is not ever-changing. I am using 0.5.3. No doubt there is something strange in Darwin internals, but I can live with it. --Dcorking 16:49, 23 August 2007 (CEST)
I can confirm that the update mostly solves this. I think if you flip it into dfu mode, and then come back, you still get a changed ethernet interface number. But it's not changing on each plug in anymore. Historybuff 20:23, 25 August 2007 (CEST)