Talk:Mac OS X

From Openmoko

Jump to: navigation, search


Comments on AJZaurus USB

First, thanks for all the hard work, it got my Neo happy and booting.

Some comments:

  • some indication when the "refresh" button is pushed that it's doing something. (Checking, downloading, etc)
  • what the status means. (F seems to mean "flashed". C means Downloaded?)
  • maybe some sanity checking? (Making sure the rootfs and kernel and uBoot aren't incompatible?)

Historybuff 19:46, 4 August 2007 (CEST)

I think that hns addressed at least the first two features in version 0.5.3. Now the GUI shows 'Cached and Flashed'. --Dcorking 16:49, 23 August 2007 (CEST)

Why AJZaurusUSB?

Q: MacOS X does work perfectly fine without AJZaurusUSB. It supports USB-Net. What do i need AJZaurusUSB for? --Deep-Thought 18:26, 16 August 2007 (CEST)

A: the Apple CDC driver has the "everchanging Ethernet interface issue" which is solved by AJZaurusUSB

A: You might have deleted the Apple CDC drivers from your system. They interfere with the RNDIS/Ethernet Gadget. 17:57, 19 August 2007

+: This does not answer the question. The AJZaurusUSB driver is actually not neccessary at all for ethernet support, because OpenMoko supports CDC ECM. Which is handled by AppleUSBCDCECMControl/AppleUSBCDCECMData. And those drivers are part of Mac OS X 10.4. I just wonder if AJZaurusUSB is even neccessary for DFU, as libusb could handle it. Problem: if you try to use dfu-util, it will complain that the USB device is already claimed by the system. --Onitake 12:36, 28 August 2007 (CEST)

Another sidenote: AJZaurusUSB just crashed my system while updating the device (with ipkg, not flashing :). AppleUSBCDCECM didn't give me such trouble so far. I think it would be best to use AJZaurusUSB only for DFU.

++: I can confirm that AJZaurusUSB is not neccessary on Mac OS X 10.4.10. The CDC ECM is fully supported by Apple's driver (which doesn't crash). And for DFU mode, we don't need a driver at all. This is handled by usermode USB (libusb). The only bad thing is that Apple's ECM driver creates a new Ethernet device each time the Neo is plugged in.

AJZaurusUSB - solves everchanging Ethernet interface issue

NOTE: it appears that after each reboot of the OpenMoko you get a new interface on the Mac (this is under investigation).[1] I am experiencing the same behaviour. Cayco

I too have the ever-changing Ethernet interface issue. Historybuff 19:46, 4 August 2007 (CEST)
Each time i plug the device in, i get a new device. But traffic on the mailing list suggest this will be fixed with static mac-addresses. --Deep-Thought 18:26, 16 August 2007 (CEST)
Has been solved in AJZaurusUSB 0.5.3 17:57, 19 August 2007
My usbnet has showed up first as en3, and another time as en4, but it is not ever-changing. I am using 0.5.3. No doubt there is something strange in Darwin internals, but I can live with it. --Dcorking 16:49, 23 August 2007 (CEST)
I can confirm that the update mostly solves this. I think if you flip it into dfu mode, and then come back, you still get a changed ethernet interface number. But it's not changing on each plug in anymore. Historybuff 20:23, 25 August 2007 (CEST)
No, the source of the problem is not DFU-Mode. It is a new kernel (version) which reports a different identity through USB. Unfortunately, there is no unique but stable serial number for each device... User:hns

Anyone flashed a 2007.2 Image from the Flasher?

I don't see where to choose the new image line. It might be one of the numbered builds, but I'm not sure where the Rosetta stone is for translating build dates/nums into which Branch it is. Historybuff 21:05, 10 September 2007 (CEST)

Doh. Took a while (and me not running from thing to thing) to get this one. Simply paste ( (or another snapshot image provider) into your dropdown box. Now I have to figure out how to do the proper erase of only kernel and rootfs (and not brick the device).
Ok, much easier then I thought. Following the instructions from here and here, it was a snap. It takes a bit of patience, but it does seem to work. Historybuff 21:40, 3 October 2007 (CEST)
Personal tools