Talk:Configure SHR for German-speaking use

From Openmoko

Revision as of 09:45, 11 June 2010 by Zoff99 (Talk | contribs)

Jump to: navigation, search

Contents

please sign your feedback, thanks !!!!!!!!!

Feedback

great work. It would be nice if the script for downloading germany.bin can be added and the dictionary setting de_AT resp. de_DE be an option during installation, so that only one script for Germany Language use can be maintained instead of one for Austria (dictionary de_AT) and one for Germany (dictionary setting de_DE). Maybe the heading could be change to German Language Use later.

--Niebert 07:40, 27 September 2009 (UTC)

i'll do that if 1 of 2 things happen:

a) many people use this (for 2 users its too much to do)

or

b) someone (you?) help me

--zoff99 12:04, 3 October 2009 (UTC)

  • mdbus warnings

Yeah, great work! Thanks for doing this and writing this guide! It worked flawlessly for me. I guess the following warnings can be safely ignored?

after

mdbus -s org.freesmartphone.ousaged /org/freesmartphone/Usage org.freesmartphone.Usage.SetResourcePolicy Display enabled

I got

Using **pending_return in dbus_connection_send_with_reply_setup() without pending_setup is deprecated and strongly discouraged
Using **pending_return in dbus_connection_send_with_reply_setup() without pending_setup is deprecated and strongly discouraged
Using **pending_return in dbus_connection_send_with_reply_setup() without pending_setup is deprecated and strongly discouraged
Using **pending_return in dbus_connection_send_with_reply_setup() without pending_setup is deprecated and strongly discouraged
Service name not found

Thanks again!

--Guido 22:09, 5 October 2009 (UTC)

yeah those warnings are normal, and can be ignored but "Service name not found" should not normally happen. when did it occur?

--zoff99 10:06, 6 October 2009 (UTC)


In Section "Preselected country in Navit", if you want to set to 'de_DE', shouldn't you edit "/media/card/____shr_testing/navit/navit.sh" instead of "/usr/bin/navit.sh"? As far as I can see there's even no "/media/card/____shr_testing/usr/bin/navit.sh".


I got a lot of error messages when starting ./init_shr_testing.sh: -./init_shr_testing.sh: line 45: mdbus: not found - Installing eet (2:1.1.0+svnr41040-r2) to root... Collected errors:

* check_data_file_clashes: Package eet wants to install file /usr/lib/libeet.so.1

But that file is already provided by package * check_data_file_clashes: libeet1

* opkg_install_cmd: Cannot install package eet.
* check_data_file_clashes: Package eet wants to install file /usr/lib/libeet.so.1

But that file is already provided by package * check_data_file_clashes: libeet1

* opkg_install_cmd: Cannot install package eet-tests.

- Configuring ecore-job. Collected errors:

* check_data_file_clashes: Package eet wants to install file /usr/lib/libeet.so.1

But that file is already provided by package * check_data_file_clashes: libeet1

* opkg_install_cmd: Cannot install package bubble-keyboard.

- Configuring libimlib2-loaders. Collected errors:

* check_data_file_clashes: Package bzip2 wants to install file /usr/lib/libbz2.so.1

But that file is already provided by package * check_data_file_clashes: libbz2-1

* check_data_file_clashes: Package bzip2 wants to install file /usr/lib/libbz2.so.1.0

But that file is already provided by package * check_data_file_clashes: libbz2-1

* opkg_install_cmd: Cannot install package qwo.

- ./init_shr_testing.sh: line 204: mdbus: not found - ./init_shr_testing.sh: line 237: mdbus: not found - Not downgrading package fsoraw on root from 1:1.0.0+gitr4+38d52c14a09dd7afc22048f2ed278e336f42a933-r2.0.4 to 0.01a+svn13-r1. - Package mokomaze (0.5.5+git8-r2.4) installed in root is up to date. Collected errors:

* print_dependents_warning: Package mokomaze is depended upon by packages:
* print_dependents_warning: 	task-shr-games
* print_dependents_warning: These might cease to work if package mokomaze is removed.
* print_dependents_warning: Force removal of this package with --force-depends.
* print_dependents_warning: Force removal of this package and its dependents
* print_dependents_warning: with --force-removal-of-dependent-packages.

- ./init_shr_testing.sh: line 296: mdbus: not found - Configuring localedef. Collected errors:

* opkg_install_cmd: Cannot install package espeak-locale.
* opkg_install_cmd: Cannot install package flite-locale.
* opkg_install_cmd: Cannot install package fso-sounds-locale.
* check_data_file_clashes: Package gconf-dbus wants to install file /usr/libexec/gconfd-2

But that file is already provided by package * check_data_file_clashes: gconf

* check_data_file_clashes: Package gconf-dbus wants to install file /usr/bin/gconftool-2

But that file is already provided by package * check_data_file_clashes: gconf

* check_data_file_clashes: Package gconf-dbus wants to install file /usr/bin/gconf-merge-tree

But that file is already provided by package * check_data_file_clashes: gconf

* check_data_file_clashes: Package gconf-dbus wants to install file /usr/lib/libgconf-2.so.4

But that file is already provided by package * check_data_file_clashes: gconf

* check_data_file_clashes: Package gconf-dbus wants to install file /etc/gconf/2/path

But that file is already provided by package * check_data_file_clashes: gconf

* opkg_install_cmd: Cannot install package gconf-dbus-locale-de.
* satisfy_dependencies_for: Cannot satisfy the following dependencies for glibc-locale-locale.alias:
* 	virtual-locale-locale.alias * 

- Configuring libwebkit-1.0-2. Collected errors:

* check_data_file_clashes: Package gst-plugins-base wants to install file /usr/lib/libgstpbutils-0.10.so.0

But that file is already provided by package * check_data_file_clashes: libgstpbutils-0.10-0

* check_data_file_clashes: Package gst-plugins-base wants to install file /usr/lib/libgstrtp-0.10.so.0

But that file is already provided by package * check_data_file_clashes: libgstrtp-0.10-0

* check_data_file_clashes: Package gst-plugins-base wants to install file /usr/lib/libgstnetbuffer-0.10.so.0

But that file is already provided by package * check_data_file_clashes: libgstnetbuffer-0.10-0

* check_data_file_clashes: Package gst-plugins-base wants to install file /usr/lib/libgstinterfaces-0.10.so.0

But that file is already provided by package * check_data_file_clashes: libgstinterfaces-0.10-0

* check_data_file_clashes: Package gst-plugins-base wants to install file /usr/lib/libgsttag-0.10.so.0

But that file is already provided by package * check_data_file_clashes: libgsttag-0.10-0

* check_data_file_clashes: Package gst-plugins-base wants to install file /usr/lib/libgstaudio-0.10.so.0

But that file is already provided by package * check_data_file_clashes: libgstaudio-0.10-0

* check_data_file_clashes: Package gst-plugins-base wants to install file /usr/lib/libgstvideo-0.10.so.0

But that file is already provided by package * check_data_file_clashes: libgstvideo-0.10-0

* opkg_install_cmd: Cannot install package midori.

- Configuring midori-locale-de.

cp: cannot stat '/media/card/____shr_testing//midori/config/speeddial.json': Path has non-directory component - Configuring cellhunter.

cp: cannot stat '/media/card/____shr_testing//.cellhunter.conf': No such file or directory - Configuring gnome-vfs. Collected errors:

* check_data_file_clashes: Package gconf-dbus wants to install file /usr/libexec/gconfd-2

But that file is already provided by package * check_data_file_clashes: gconf

* check_data_file_clashes: Package gconf-dbus wants to install file /usr/bin/gconftool-2

But that file is already provided by package * check_data_file_clashes: gconf

* check_data_file_clashes: Package gconf-dbus wants to install file /usr/bin/gconf-merge-tree

But that file is already provided by package * check_data_file_clashes: gconf

* check_data_file_clashes: Package gconf-dbus wants to install file /usr/lib/libgconf-2.so.4

But that file is already provided by package * check_data_file_clashes: gconf

* check_data_file_clashes: Package gconf-dbus wants to install file /etc/gconf/2/path

But that file is already provided by package * check_data_file_clashes: gconf

* opkg_install_cmd: Cannot install package rsvg.

- Configuring ncurses-terminfo. Collected errors:

* check_data_file_clashes: Package e2fsprogs-libs wants to install file /usr/bin/mk_cmds

But that file is already provided by package * check_data_file_clashes: e2fsprogs

* check_data_file_clashes: Package e2fsprogs-libs wants to install file /usr/bin/compile_et

But that file is already provided by package * check_data_file_clashes: e2fsprogs

* check_data_file_clashes: Package e2fsprogs-libs wants to install file /usr/lib/libuuid.so.1

But that file is already provided by package * check_data_file_clashes: libuuid1

* check_data_file_clashes: Package e2fsprogs-libs wants to install file /usr/lib/libcom_err.so.2

But that file is already provided by package * check_data_file_clashes: libcom-err2

* check_data_file_clashes: Package e2fsprogs-libs wants to install file /usr/lib/libblkid.so.1

But that file is already provided by package * check_data_file_clashes: libblkid1

* check_data_file_clashes: Package e2fsprogs-libs wants to install file /usr/lib/libss.so.2

But that file is already provided by package * check_data_file_clashes: libss2

* check_data_file_clashes: Package e2fsprogs-libs wants to install file /usr/lib/libcom_err.so.2.1

But that file is already provided by package * check_data_file_clashes: libcom-err2

* check_data_file_clashes: Package e2fsprogs-libs wants to install file /usr/lib/libss.so.2.0

But that file is already provided by package * check_data_file_clashes: libss2

* opkg_install_cmd: Cannot install package mc.

- cp: cannot stat '/media/card/____shr_testing//shr_settings/gprs.pickle': No such file or directory

cp: cannot stat '/media/card/____shr_testing//a-gps/etc_agps-online.conf': No such file or directory - cp: cannot stat '/media/card/____shr_testing//etc_sms-sentry.conf': No such file or directory - Configuring python-html. Collected errors:

* check_data_file_clashes: Package python-misc wants to install file /usr/lib/python2.6/ssl.pyo

But that file is already provided by package * check_data_file_clashes: python-io

* check_data_file_clashes: Package python-misc wants to install file /usr/lib/python2.6/ssl.py

But that file is already provided by package * check_data_file_clashes: python-io

* opkg_install_cmd: Cannot install package advancedcaching.

rm: /home/root/Maps/OSM: is a directory rmdir: '/home/root/Maps': Directory not empty

cp: cannot stat '/media/card/____shr_testing//geocaching/config': No such file or directory cp: cannot stat '/media/card/____shr_testing/geocaching/simplegui.py': No such file or directory cp: cannot stat '/media/card/____shr_testing/geocaching/geocaching.py': No such file or directory - rm: cannot remove 'illume-shr': No such file or directory

May I ignore these messages? Or will I have a corrupted System? btw: I'm running SHR-U (http://build.shr-project.org/shr-unstable/images/om-gta02/full-om-gta02.tar.gz - 09-Jun-2010 10:21, 76M) on uSD.

--ChrisPZV 10 June 2010 (UTC)


Hi Chris!

this will NOT work with current SHR distros!!! if you really want to use this, download exactly those files which are listed on my page. as far as new SHR distro, I can only say its so unstable and slow, i dont use it anymore.

cheers, Zoff.

--zoff99 08:45, 11 June 2010 (UTC)

Problem using settings

great work. but i've 2 problems(?) First: Using Settings: Using: Settings => Power => Please wait... Loading 4 modules

That's all. No more action. It is only possible to kill the settings-process. One time after the first update it works. But after the next reboot settings doesn't work any more. Can anyone help me, to fix this problem ?

Second: I got the error message: Service name not found too. (After using: mdbus -s org.freesmartphone.ousaged /org/freesmartphone/Usage org.freesmartphone.Usage.SetResourcePolicy Display enabled)

Many thanks. Andre

--Steigera 09:47, 18 October 2009 (UTC)


did you do update & upgrade also? if not, do so

and did you start settings right after boot-up? because frameworkd is really really slow, and needs a couple of minutes to have everything loaded.

if that does not help start "shr-settings" on the ssh-console and put the output here

--zoff99 11:17, 18 October 2009 (UTC)

yes. I've tried to use settings very fast after boot-up. Now after some minutes it works :-)). Thanks for your fast response. But another question: it is a little bit extensive to modify the power-settings after every boot-up. e.g: Backlight Is there a possibility to modify these settings so it will be used after next boot-up ?

--Steigera 18 October 2009 (UTC)

PLEASE use the "sign" button when writing here!!

sure there is a way, write a script with "mdbus -s XXX YYY" and put it somewhere after system startup.

--zoff99 17:08, 18 October 2009 (UTC)

What do you think about

#install German
opkg list_installed | cut -d " " -f1 | grep -v "kernel-module"> /tmp/opkgi.txt
opkg list | cut -d " " -f1 | grep -v "kernel-module"> /tmp/opkg.txt
grep locale-de /tmp/opkg.txt > /tmp/opkg_de.txt
grep i18n /tmp/opkg.txt >> /tmp/opkg_de.txt
for ip in $(cat /tmp/opkgi.txt)
do
   prog=$(grep $ip /tmp/opkg_de.txt)
   if [ $prog ]
   then
	echo found $prog
	install="$install $prog"
   fi
done
opkg install $install

this installs to all installed packed the locale-de package, if found

--Bertol 14:40, 29 November 2009

i dont think its too good. for example when you install german locale for "ls, cp" you get weird german messages from your shell commands. also the phone GUIs (call, messages, etc.) are really strange in german (and sometimes translation is just wrong)

--zoff99 14:10, 29 November 2009 (UTC)

Personal tools

please sign your feedback, thanks !!!!!!!!!

Feedback

great work. It would be nice if the script for downloading germany.bin can be added and the dictionary setting de_AT resp. de_DE be an option during installation, so that only one script for Germany Language use can be maintained instead of one for Austria (dictionary de_AT) and one for Germany (dictionary setting de_DE). Maybe the heading could be change to German Language Use later.

--Niebert 07:40, 27 September 2009 (UTC)

i'll do that if 1 of 2 things happen:

a) many people use this (for 2 users its too much to do)

or

b) someone (you?) help me

--zoff99 12:04, 3 October 2009 (UTC)

  • mdbus warnings

Yeah, great work! Thanks for doing this and writing this guide! It worked flawlessly for me. I guess the following warnings can be safely ignored?

after

mdbus -s org.freesmartphone.ousaged /org/freesmartphone/Usage org.freesmartphone.Usage.SetResourcePolicy Display enabled

I got

Using **pending_return in dbus_connection_send_with_reply_setup() without pending_setup is deprecated and strongly discouraged
Using **pending_return in dbus_connection_send_with_reply_setup() without pending_setup is deprecated and strongly discouraged
Using **pending_return in dbus_connection_send_with_reply_setup() without pending_setup is deprecated and strongly discouraged
Using **pending_return in dbus_connection_send_with_reply_setup() without pending_setup is deprecated and strongly discouraged
Service name not found

Thanks again!

--Guido 22:09, 5 October 2009 (UTC)

yeah those warnings are normal, and can be ignored but "Service name not found" should not normally happen. when did it occur?

--zoff99 10:06, 6 October 2009 (UTC)


In Section "Preselected country in Navit", if you want to set to 'de_DE', shouldn't you edit "/media/card/____shr_testing/navit/navit.sh" instead of "/usr/bin/navit.sh"? As far as I can see there's even no "/media/card/____shr_testing/usr/bin/navit.sh".


I got a lot of error messages when starting ./init_shr_testing.sh: -./init_shr_testing.sh: line 45: mdbus: not found - Installing eet (2:1.1.0+svnr41040-r2) to root... Collected errors:

* check_data_file_clashes: Package eet wants to install file /usr/lib/libeet.so.1

But that file is already provided by package * check_data_file_clashes: libeet1

* opkg_install_cmd: Cannot install package eet.
* check_data_file_clashes: Package eet wants to install file /usr/lib/libeet.so.1

But that file is already provided by package * check_data_file_clashes: libeet1

* opkg_install_cmd: Cannot install package eet-tests.

- Configuring ecore-job. Collected errors:

* check_data_file_clashes: Package eet wants to install file /usr/lib/libeet.so.1

But that file is already provided by package * check_data_file_clashes: libeet1

* opkg_install_cmd: Cannot install package bubble-keyboard.

- Configuring libimlib2-loaders. Collected errors:

* check_data_file_clashes: Package bzip2 wants to install file /usr/lib/libbz2.so.1

But that file is already provided by package * check_data_file_clashes: libbz2-1

* check_data_file_clashes: Package bzip2 wants to install file /usr/lib/libbz2.so.1.0

But that file is already provided by package * check_data_file_clashes: libbz2-1

* opkg_install_cmd: Cannot install package qwo.

- ./init_shr_testing.sh: line 204: mdbus: not found - ./init_shr_testing.sh: line 237: mdbus: not found - Not downgrading package fsoraw on root from 1:1.0.0+gitr4+38d52c14a09dd7afc22048f2ed278e336f42a933-r2.0.4 to 0.01a+svn13-r1. - Package mokomaze (0.5.5+git8-r2.4) installed in root is up to date. Collected errors:

* print_dependents_warning: Package mokomaze is depended upon by packages:
* print_dependents_warning: 	task-shr-games
* print_dependents_warning: These might cease to work if package mokomaze is removed.
* print_dependents_warning: Force removal of this package with --force-depends.
* print_dependents_warning: Force removal of this package and its dependents
* print_dependents_warning: with --force-removal-of-dependent-packages.

- ./init_shr_testing.sh: line 296: mdbus: not found - Configuring localedef. Collected errors:

* opkg_install_cmd: Cannot install package espeak-locale.
* opkg_install_cmd: Cannot install package flite-locale.
* opkg_install_cmd: Cannot install package fso-sounds-locale.
* check_data_file_clashes: Package gconf-dbus wants to install file /usr/libexec/gconfd-2

But that file is already provided by package * check_data_file_clashes: gconf

* check_data_file_clashes: Package gconf-dbus wants to install file /usr/bin/gconftool-2

But that file is already provided by package * check_data_file_clashes: gconf

* check_data_file_clashes: Package gconf-dbus wants to install file /usr/bin/gconf-merge-tree

But that file is already provided by package * check_data_file_clashes: gconf

* check_data_file_clashes: Package gconf-dbus wants to install file /usr/lib/libgconf-2.so.4

But that file is already provided by package * check_data_file_clashes: gconf

* check_data_file_clashes: Package gconf-dbus wants to install file /etc/gconf/2/path

But that file is already provided by package * check_data_file_clashes: gconf

* opkg_install_cmd: Cannot install package gconf-dbus-locale-de.
* satisfy_dependencies_for: Cannot satisfy the following dependencies for glibc-locale-locale.alias:
* 	virtual-locale-locale.alias * 

- Configuring libwebkit-1.0-2. Collected errors:

* check_data_file_clashes: Package gst-plugins-base wants to install file /usr/lib/libgstpbutils-0.10.so.0

But that file is already provided by package * check_data_file_clashes: libgstpbutils-0.10-0

* check_data_file_clashes: Package gst-plugins-base wants to install file /usr/lib/libgstrtp-0.10.so.0

But that file is already provided by package * check_data_file_clashes: libgstrtp-0.10-0

* check_data_file_clashes: Package gst-plugins-base wants to install file /usr/lib/libgstnetbuffer-0.10.so.0

But that file is already provided by package * check_data_file_clashes: libgstnetbuffer-0.10-0

* check_data_file_clashes: Package gst-plugins-base wants to install file /usr/lib/libgstinterfaces-0.10.so.0

But that file is already provided by package * check_data_file_clashes: libgstinterfaces-0.10-0

* check_data_file_clashes: Package gst-plugins-base wants to install file /usr/lib/libgsttag-0.10.so.0

But that file is already provided by package * check_data_file_clashes: libgsttag-0.10-0

* check_data_file_clashes: Package gst-plugins-base wants to install file /usr/lib/libgstaudio-0.10.so.0

But that file is already provided by package * check_data_file_clashes: libgstaudio-0.10-0

* check_data_file_clashes: Package gst-plugins-base wants to install file /usr/lib/libgstvideo-0.10.so.0

But that file is already provided by package * check_data_file_clashes: libgstvideo-0.10-0

* opkg_install_cmd: Cannot install package midori.

- Configuring midori-locale-de.

cp: cannot stat '/media/card/____shr_testing//midori/config/speeddial.json': Path has non-directory component - Configuring cellhunter.

cp: cannot stat '/media/card/____shr_testing//.cellhunter.conf': No such file or directory - Configuring gnome-vfs. Collected errors:

* check_data_file_clashes: Package gconf-dbus wants to install file /usr/libexec/gconfd-2

But that file is already provided by package * check_data_file_clashes: gconf

* check_data_file_clashes: Package gconf-dbus wants to install file /usr/bin/gconftool-2

But that file is already provided by package * check_data_file_clashes: gconf

* check_data_file_clashes: Package gconf-dbus wants to install file /usr/bin/gconf-merge-tree

But that file is already provided by package * check_data_file_clashes: gconf

* check_data_file_clashes: Package gconf-dbus wants to install file /usr/lib/libgconf-2.so.4

But that file is already provided by package * check_data_file_clashes: gconf

* check_data_file_clashes: Package gconf-dbus wants to install file /etc/gconf/2/path

But that file is already provided by package * check_data_file_clashes: gconf

* opkg_install_cmd: Cannot install package rsvg.

- Configuring ncurses-terminfo. Collected errors:

* check_data_file_clashes: Package e2fsprogs-libs wants to install file /usr/bin/mk_cmds

But that file is already provided by package * check_data_file_clashes: e2fsprogs

* check_data_file_clashes: Package e2fsprogs-libs wants to install file /usr/bin/compile_et

But that file is already provided by package * check_data_file_clashes: e2fsprogs

* check_data_file_clashes: Package e2fsprogs-libs wants to install file /usr/lib/libuuid.so.1

But that file is already provided by package * check_data_file_clashes: libuuid1

* check_data_file_clashes: Package e2fsprogs-libs wants to install file /usr/lib/libcom_err.so.2

But that file is already provided by package * check_data_file_clashes: libcom-err2

* check_data_file_clashes: Package e2fsprogs-libs wants to install file /usr/lib/libblkid.so.1

But that file is already provided by package * check_data_file_clashes: libblkid1

* check_data_file_clashes: Package e2fsprogs-libs wants to install file /usr/lib/libss.so.2

But that file is already provided by package * check_data_file_clashes: libss2

* check_data_file_clashes: Package e2fsprogs-libs wants to install file /usr/lib/libcom_err.so.2.1

But that file is already provided by package * check_data_file_clashes: libcom-err2

* check_data_file_clashes: Package e2fsprogs-libs wants to install file /usr/lib/libss.so.2.0

But that file is already provided by package * check_data_file_clashes: libss2

* opkg_install_cmd: Cannot install package mc.

- cp: cannot stat '/media/card/____shr_testing//shr_settings/gprs.pickle': No such file or directory

cp: cannot stat '/media/card/____shr_testing//a-gps/etc_agps-online.conf': No such file or directory - cp: cannot stat '/media/card/____shr_testing//etc_sms-sentry.conf': No such file or directory - Configuring python-html. Collected errors:

* check_data_file_clashes: Package python-misc wants to install file /usr/lib/python2.6/ssl.pyo

But that file is already provided by package * check_data_file_clashes: python-io

* check_data_file_clashes: Package python-misc wants to install file /usr/lib/python2.6/ssl.py

But that file is already provided by package * check_data_file_clashes: python-io

* opkg_install_cmd: Cannot install package advancedcaching.

rm: /home/root/Maps/OSM: is a directory rmdir: '/home/root/Maps': Directory not empty

cp: cannot stat '/media/card/____shr_testing//geocaching/config': No such file or directory cp: cannot stat '/media/card/____shr_testing/geocaching/simplegui.py': No such file or directory cp: cannot stat '/media/card/____shr_testing/geocaching/geocaching.py': No such file or directory - rm: cannot remove 'illume-shr': No such file or directory

May I ignore these messages? Or will I have a corrupted System? btw: I'm running SHR-U (http://build.shr-project.org/shr-unstable/images/om-gta02/full-om-gta02.tar.gz - 09-Jun-2010 10:21, 76M) on uSD.

--ChrisPZV 10 June 2010 (UTC)


Hi Chris!

this will NOT work with current SHR distros!!! if you really want to use this, download exactly those files which are listed on my page. as far as new SHR distro, I can only say its so unstable and slow, i dont use it anymore.

cheers, Zoff.

--zoff99 08:45, 11 June 2010 (UTC)

Problem using settings

great work. but i've 2 problems(?) First: Using Settings: Using: Settings => Power => Please wait... Loading 4 modules

That's all. No more action. It is only possible to kill the settings-process. One time after the first update it works. But after the next reboot settings doesn't work any more. Can anyone help me, to fix this problem ?

Second: I got the error message: Service name not found too. (After using: mdbus -s org.freesmartphone.ousaged /org/freesmartphone/Usage org.freesmartphone.Usage.SetResourcePolicy Display enabled)

Many thanks. Andre

--Steigera 09:47, 18 October 2009 (UTC)


did you do update & upgrade also? if not, do so

and did you start settings right after boot-up? because frameworkd is really really slow, and needs a couple of minutes to have everything loaded.

if that does not help start "shr-settings" on the ssh-console and put the output here

--zoff99 11:17, 18 October 2009 (UTC)

yes. I've tried to use settings very fast after boot-up. Now after some minutes it works :-)). Thanks for your fast response. But another question: it is a little bit extensive to modify the power-settings after every boot-up. e.g: Backlight Is there a possibility to modify these settings so it will be used after next boot-up ?

--Steigera 18 October 2009 (UTC)

PLEASE use the "sign" button when writing here!!

sure there is a way, write a script with "mdbus -s XXX YYY" and put it somewhere after system startup.

--zoff99 17:08, 18 October 2009 (UTC)

What do you think about

#install German
opkg list_installed | cut -d " " -f1 | grep -v "kernel-module"> /tmp/opkgi.txt
opkg list | cut -d " " -f1 | grep -v "kernel-module"> /tmp/opkg.txt
grep locale-de /tmp/opkg.txt > /tmp/opkg_de.txt
grep i18n /tmp/opkg.txt >> /tmp/opkg_de.txt
for ip in $(cat /tmp/opkgi.txt)
do
   prog=$(grep $ip /tmp/opkg_de.txt)
   if [ $prog ]
   then
	echo found $prog
	install="$install $prog"
   fi
done
opkg install $install

this installs to all installed packed the locale-de package, if found

--Bertol 14:40, 29 November 2009

i dont think its too good. for example when you install german locale for "ls, cp" you get weird german messages from your shell commands. also the phone GUIs (call, messages, etc.) are really strange in german (and sometimes translation is just wrong)

--zoff99 14:10, 29 November 2009 (UTC)