Talk:Configure SHR for German-speaking use

From Openmoko

Jump to: navigation, search


please sign your feedback, thanks !!!!!!!!!


great work. It would be nice if the script for downloading germany.bin can be added and the dictionary setting de_AT resp. de_DE be an option during installation, so that only one script for Germany Language use can be maintained instead of one for Austria (dictionary de_AT) and one for Germany (dictionary setting de_DE). Maybe the heading could be change to German Language Use later.

--Niebert 07:40, 27 September 2009 (UTC)

i'll do that if 1 of 2 things happen:

a) many people use this (for 2 users its too much to do)


b) someone (you?) help me

--zoff99 12:04, 3 October 2009 (UTC)

  • mdbus warnings

Yeah, great work! Thanks for doing this and writing this guide! It worked flawlessly for me. I guess the following warnings can be safely ignored?


mdbus -s org.freesmartphone.ousaged /org/freesmartphone/Usage org.freesmartphone.Usage.SetResourcePolicy Display enabled

I got

Using **pending_return in dbus_connection_send_with_reply_setup() without pending_setup is deprecated and strongly discouraged
Using **pending_return in dbus_connection_send_with_reply_setup() without pending_setup is deprecated and strongly discouraged
Using **pending_return in dbus_connection_send_with_reply_setup() without pending_setup is deprecated and strongly discouraged
Using **pending_return in dbus_connection_send_with_reply_setup() without pending_setup is deprecated and strongly discouraged
Service name not found

Thanks again!

--Guido 22:09, 5 October 2009 (UTC)

yeah those warnings are normal, and can be ignored but "Service name not found" should not normally happen. when did it occur?

--zoff99 10:06, 6 October 2009 (UTC)

In Section "Preselected country in Navit", if you want to set to 'de_DE', shouldn't you edit "/media/card/____shr_testing/navit/" instead of "/usr/bin/"? As far as I can see there's even no "/media/card/____shr_testing/usr/bin/".

I got a lot of error messages when starting ./ May I ignore all the messages? Or will I have a corrupted System? btw: I'm running SHR-U ( - 09-Jun-2010 10:21, 76M) on uSD.

--ChrisPZV 10 June 2010 (UTC)

Hi Chris!

this will NOT work with current SHR distros!!! if you really want to use this, download exactly those files which are listed on my page. as far as new SHR distro, I can only say its so unstable and slow, i dont use it anymore.

cheers, Zoff.

--zoff99 08:45, 11 June 2010 (UTC)

About section Mokonnect: (i have NOT yet successfully connected to any WLAN networks) --> me too, may be 'iliwi' (opkg update && opkg remove --force-depends mokonnect && opkg install iliwi) provides the missing functionality here? After installing all updates it works for me, but auto disconnect WLAN on close programm does not work. Woraround: Manage it with the help of profiles, make a profile that just uses USB Network and check "Power down unused devices" when selecting it. (I installed connman-plugin-ethernet)

Btw AGTL is outdated, it should be updated from the package at (At this time it needs to be patched as I described in user comment.)

Did you consider installing Pisi as well? (

Is there any working bluetooth support?

--ChrisPZV 11 June 2010 (UTC)

--ChrisPZV 09:21, 16 June 2010 (UTC)

as you can see i am not working on this anymore. but it should still be usable. SHR has moved in a direction of beeing slow and unstable and unusable, so i am not updating these packages anymore.

--zoff99 07:42, 17 June 2010 (UTC)

Problem using settings

great work. but i've 2 problems(?) First: Using Settings: Using: Settings => Power => Please wait... Loading 4 modules

That's all. No more action. It is only possible to kill the settings-process. One time after the first update it works. But after the next reboot settings doesn't work any more. Can anyone help me, to fix this problem ?

Second: I got the error message: Service name not found too. (After using: mdbus -s org.freesmartphone.ousaged /org/freesmartphone/Usage org.freesmartphone.Usage.SetResourcePolicy Display enabled)

Many thanks. Andre

--Steigera 09:47, 18 October 2009 (UTC)

did you do update & upgrade also? if not, do so

and did you start settings right after boot-up? because frameworkd is really really slow, and needs a couple of minutes to have everything loaded.

if that does not help start "shr-settings" on the ssh-console and put the output here

--zoff99 11:17, 18 October 2009 (UTC)

yes. I've tried to use settings very fast after boot-up. Now after some minutes it works :-)). Thanks for your fast response. But another question: it is a little bit extensive to modify the power-settings after every boot-up. e.g: Backlight Is there a possibility to modify these settings so it will be used after next boot-up ?

--Steigera 18 October 2009 (UTC)

PLEASE use the "sign" button when writing here!!

sure there is a way, write a script with "mdbus -s XXX YYY" and put it somewhere after system startup.

--zoff99 17:08, 18 October 2009 (UTC)

What do you think about

#install German
opkg list_installed | cut -d " " -f1 | grep -v "kernel-module"> /tmp/opkgi.txt
opkg list | cut -d " " -f1 | grep -v "kernel-module"> /tmp/opkg.txt
grep locale-de /tmp/opkg.txt > /tmp/opkg_de.txt
grep i18n /tmp/opkg.txt >> /tmp/opkg_de.txt
for ip in $(cat /tmp/opkgi.txt)
   prog=$(grep $ip /tmp/opkg_de.txt)
   if [ $prog ]
	echo found $prog
	install="$install $prog"
opkg install $install

this installs to all installed packed the locale-de package, if found

--Bertol 14:40, 29 November 2009

i dont think its too good. for example when you install german locale for "ls, cp" you get weird german messages from your shell commands. also the phone GUIs (call, messages, etc.) are really strange in german (and sometimes translation is just wrong)

--zoff99 14:10, 29 November 2009 (UTC)

Personal tools