Knjrepository

From Openmoko

Revision as of 10:33, 4 February 2009 by Kaspernj (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Packages

The knjRepository includes the following interesting packages:

  1. php526 - PHP 5.2.6 CLI support, which enables you to write CLI-scripts for your OpenMoko. It also includes PDO (SQLite3) support.
  2. php526-gtk2 - PHP-GTK enables you to write GTK-applications in PHP.
  3. ruby1.8 - Enables you to use Ruby scripts on your OpenMoko.
  4. libgtk2-ruby1.8 - Enables Ruby to use Gtk.
  5. libsqlite3-ruby1.8 - Enables you to use SQLite3-databases in Ruby.
  6. libglade2-ruby1.8 - Enables you to use Glade with Gtk-applications in Ruby.


(and a lot of other Ruby-extensions like SOAP and WSDL)


How to use

You can configure your phone to use the repository by doing the following:

wget http://downloads.kaspernj.org/openmoko/repository/knjrepository.conf -O /etc/opkg/knjrepository.conf

opkg update

(ignore the signature errors)


Then if you want to install PHP-GTK, you can do this:

opkg install php526 php526-gtk2


Or if you want Ruby with Gtk-support:

opkg install ruby1.8 libgtk2-ruby1.8 libglade2-ruby1.8 libsqlite3-ruby


Made by

The repository has been set up and is maintained by Kasper Johansen.

Personal tools

Packages

The knjRepository includes the following interesting packages:

  1. php526 - PHP 5.2.6 CLI support, which enables you to write CLI-scripts for your OpenMoko. It also includes PDO (SQLite3) support.
  2. php526-gtk2 - PHP-GTK enables you to write GTK-applications in PHP.
  3. ruby1.8 - Enables you to use Ruby scripts on your OpenMoko.
  4. libgtk2-ruby1.8 - Enables Ruby to use Gtk.
  5. libsqlite3-ruby1.8 - Enables you to use SQLite3-databases in Ruby.
  6. libglade2-ruby1.8 - Enables you to use Glade with Gtk-applications in Ruby.


(and a lot of other Ruby-extensions like SOAP and WSDL)


How to use

You can configure your phone to use the repository by doing the following:

wget http://downloads.kaspernj.org/openmoko/repository/knjrepository.conf -O /etc/opkg/knjrepository.conf

opkg update

(ignore the signature errors)


Then if you want to install PHP-GTK, you can do this:

opkg install php526 php526-gtk2


Or if you want Ruby with Gtk-support:

opkg install ruby1.8 libgtk2-ruby1.8 libglade2-ruby1.8 libsqlite3-ruby


Made by

The repository has been set up and is maintained by Kasper Johansen.