From Openmoko

Jump to: navigation, search


When I do

insmod drivers/media/video/v4l1-compat.ko 

I have

insmod: error inserting 'drivers/media/video/v4l1-compat.ko': -1 Invalid module format

and in dmesg

v4l1_compat: version magic '2.6.24 preempt mod_unload ARMv4 ' should be '2.6.24-20081103.git7172ec57 preempt mod_unload ARMv4 '

Have you a idea ?


I guess the real fix would be to use the 2.6.24-20081103.git7172ec57 source instead of the 2.6.24 one, but there's also another workaround. Just attach EXTRAVERSION=-20081103.git7172ec57 whenever you build (use make) a file, e.g.:

make EXTRAVERSION=-20081103.git7172ec57 drivers/media/video/v4l1-compat.ko


These steps may also work on SHR if you

  opkg install binutils gcc-symlinks gcc g++ make

If you're getting "error trying to exec 'cc1': execvp: No such file or directory" or "cannot find gcc" you need the symlinks package and binutils.

Personal tools