Talk:Neo 1973 and Windows

From Openmoko

Jump to: navigation, search

This procedure works for me, Windows XP SP2 and Neo kernel Linux fic-gta01 I can even do ipkg update/upgrade with the routing in place. hhf423


Troubles installing the Neo1973.inf on Windows

I had some difficulties, but could do it like this:

- Download Neo1973.inf

- Rightclick the Neo1973.inf "Install"

- Rightclick the Workspace, Properties, select tab "Hardware", Button "Device Manager"

- The "Linux USB Ethernet/RNDIS Gadget" was not correctely installed

- Rightclick "Update driver", select the same driver you downloaded before (Neo1973.inf)

... and it worked :-)


No needs to enter an IP into the configuration panel, the ".inf" file do the job. It seems "

XP Professional x64

Took some tweaking to get my Neo to work under XP Pro x64... in the end I used the Vista inf neo_vista_x64 and modified the line

AddReg          = RNDIS_AddReg_Vista

and changed it to

AddReg          = RNDIS_AddReg_XP

worked like a champ after that!

Vista 32-bit

With Windows Vista Business 32 bit I was unable to install any of the INF files.

Another maybe quite unsecure method (WinXP Professional 32 Bit)

All the options listed on the Neo and Windows-site didn't really work for me to get an internetconnection working for my freerunner.

I tried the following and it worked fine for me: 1. downloaded the .inf-file, and all that stuff so i could connect via putty. that was no problem. 2. going to the Control Panel > Network Connections and selecting the Local Area Connection of my pc 3. right-click > Properties > tab "Advanced" (the third in the row) > "Internet Connection Sharing" > toggle the button "Allow other network users to connect through this computer's Internet connection" 4. switching off the windows firewall 5. internet is reachable!!! :)

works with kernel 2.6.24.

can anyone reproduce that or confirm or critizise that and, if alright, write it on the real page? thanx

Windows 7 does not seem to need an external driver

I could not get the Neo_vista_x64.inf to work. So I used "Update Drivers" and selected Select from a list of drivers. From there I chose Microsoft Corporation and RNDIS compatible device. After this and setting up the static IP, ssh works fine.

Personal tools