Talk:Manually using Bluetooth

From Openmoko

Jump to: navigation, search


Bluetooth keyboards which doesn't support HID

There exists several bluetooth keyboards which doesn't support the normal HID protocol. This means you can not simply use "hidd --connect 11:22:33:44:55:66". I've searched the net a bit and found this: The program kbdd seems like the thing to use. The source code is available. I'm not able to test this program myself as I do not have a Neo yet. EsbenDamgaard 22:10, 16 August 2007 (CEST)

I have tried it and it works ok for me, there is even an ipkg package for kbdd in Angstrom, see the details in . --Glownan 10:56, 14 November 2008 (UTC)

Phone does not detect laptop

If running hcitool scan on the phone does not detect your laptop, check if ISCAN is enabled on the laptop by typing hciconfig and seeing the output.Like in the following output ISCAN is not enabled.

       hci0:   Type: USB
               BD Address: 00:19:7E:E5:C2:2F ACL MTU: 1017:8 SCO MTU: 64:8
               UP RUNNING PSCAN 
               RX bytes:1651 acl:0 sco:0 events:42 errors:0
               TX bytes:368 acl:0 sco:0 commands:31 errors:0

It is not enabled by default on Ubuntu Edgy systems.

If it is not then either type : hciconfig hci0 piscan

Also you can permanently fix this bug by doing the following steps on the laptop:

1. Add "discovto 0;" to the device section of hcid.conf file in /etc/bluetooth.

2. Remove all the files present in /var/lib/bluetooth

3. Restart Bluetooth

4. Check hciconfig and ISCAN will be enabled.Deepank 20:21, 22 August 2007

This does not work with 2007.2 / .08 image plus ipkg updates up until August 24?

After starting everything as described, I only get error messages:

root@fic-gta01:~$ hciconfig
Can't open HCI socket.: Address family not supported by protocol
root@fic-gta01:~$ modprobe gta01-pm-bt
FATAL: Module gta01_pm_bt not found.
root@fic-gta01:~$ modprobe hci_usb    
WARNING: Could not open '/lib/modules/': No such file or directory
FATAL: Could not open '/lib/modules/': No such file or directory

Can someone let me know if BT is supposed to work with 2007.2 / .08 plus updates?

This issue is SOLVED, in a way: kernel seems to be required.


Bluetooth keyboards which doesn't support HID: tested a keyboard

I've tested a "Freedom Universal Keyboard", model G912. Wiki says it should work but...

Doesn't connect on HID mode (connection reset by peer), while on SPP just gives wrong characters, and also keeps sending chars even when not typing.

Used kbdd too, this time on my desktop with usb dongle. Same thing as above, maybe this model is incompatible/needs special driver?

Kiantis - 31 Aug 2008

I configured the G912 (Freedom Universal Keyboard²) in SPP and directly read serial input. There you get for each typed key a byte. If the MSB is not set (0x80) the key is pressed. With python I managed to feed this keys to /dev/input/uinput. But in the moment I think the script is only usable by myself.--Plaicy 21:31, 31 December 2008 (UTC)

fyi: (don't know what model it is off hand). --tim_abell 03:16, 25 January 2009 (UTC)

Which rules.yaml file?

I have found some rules.yaml files, which do you mean in the main article? I would sugguest here using the absolute path. :) --Quix0r 12:33, 16 July 2009 (UTC)

I use paroli-testing5 here and the file in question is /etc/freesmartphone/oevents/old_rules.yaml. The modification is already done so (I think, need confirmation here) no patching for paroli-testing5 users --Quix0r 13:22, 16 July 2009 (UTC)

Headset reconnect after resume?

Is there any solution that automatically reconnects the bt headset after suspend/resume, or could it be possible to keep the bt chip polling the headset every few seconds even while in suspend(If not, I consider it a design flaw, all bt headsets turn off after a few minutes without connection.) I tried coding a suspend/resume reconnector in fso some time back, but it didn't solve anything because my headset always turned off after a minute or two of fr suspend.--Rakshasa 08:14, 9 December 2009 (UTC)

Personal tools