Adobe Flash

From Openmoko

Jump to: navigation, search
TODO: This page is a stub. (See: To-Do List)

Adobe Flash is not supported on Openmoko. We recommend Gnash. Gnash is a free software swf file player that supports up to swf version 8, with swf v9 currently under heavy development. It fully supports streaming video from popular web sites, and most flash based animations. On the Openmoko, Gnash has to use 100% software rendering, so some things, like streaming video over the internet has performance issues at this time.

A screenshot of Gnash on the NEO 1973 is here:


NOTE: The version linked to is outdated and therefore not recommendable.

Ipk packages of Gnash for the Openmoko are available from:

If you want to install Gnash, here's how:

opkg install


In case opkg complains about libagg2 missing, you'll have to add the angstrom repository. Here's how to add the repository and have opkg install gnash with all neccesary dependencies:

echo "src/gz angstrom-armv4t" > /etc/opkg/angstrom-feed.conf
opkg update
opkg install

In case opkg only complains about gtk+-fastscaling, you can ignore this error and install with:

opkg --force-depends install

if you have a problem with loading shared library, install it with opkg install:

opkg install
Personal tools