User:Twistedclone

From Openmoko

Revision as of 13:50, 27 July 2009 by Twistedclone (Talk | contribs)

Jump to: navigation, search

Contents

Android USB networking

Add default gateway

route add default gw 192.168.0.200 dev usb0

Wifi Connection on Android

Wifi Wext interface How to tether your G1 Forum wlan configured

Android Compilation

Compiling Your Own G1 Kernel Modules

Android porting

port on real device Android toolchain

Tips and Trick

Mount Android fs rw mode

wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf

Decompiling lib file (*.so)

dpkg -S /path/filename.so strings /path/filename.so Add find command

Openmoko Emulator Setup

OS: Ubuntu 8.10

We run the following commands:

sudo apt-get install monotone git-core git-svn git-email \ git-cvs git-arch gitk python-dev ccache m4 sed bison make cvs gawk \ libc6-dev g++ subversion sharutils docbook openjade quilt libmpfr-dev \ libpcre3-dev texinfo texi2html libboost-date-time-dev libboost-filesystem-dev \ libboost-regex-dev libboost-test-dev libboost-dev zlib1g-dev build-essential \ dh-make debhelper devscripts gcc-3.4 lynx netpbm libsdl1.2-dev dosfstools \ help2man python-psyco lynx

mkdir openmoko

cd openmoko

wget http://www.rwhitby.net/files/openmoko/Makefile

make qemu

The emulator is opened. After splash screen the Boot menu appears. By choosing the "Boot" item the following messages are printed and booting process is interrupted:

  Booting kernel from Legacy Image at 30100000 ...
  Image Name:   openmoko/2.6.24-oe5+gitrfb42ce67
  Created:      2009-02-15   3:19:24 UTC
  Image Type:   ARM Linux Kernel Image (uncompressed)
  Data Size:    1914900 Bytes =  1.8 MB
  Load Address: 30008000
  Entry Point:  30008000
  Verifying Checksum ... OK
  Loading Kernel Image ...


We tried to launch the Emulator with different values of the following parameters specified in build/qemu/openmoko/env file, but it didn't help. For instance:

kernel_wildcard="uImage-2.6.28-oe1+gitr34240a1c06ae36180dee695aa25bbae869b2aa26-r3-om-gta01.bin" rootfs_wildcard="openmoko-fso-image-nox-glibc-ipk--20090216-om-gta01.rootfs.jffs2" uboot_wildcard="u-boot-gta01bv4-1.3.1+gitr650149a53dbdd48bf6dfef90930c8ab182adb512-r1.bin"

download_dir="http://downloads.openmoko.org/distro/unstable/daily/om-gta01/20090216/"


Does anyone have any idea how to fix the problem concerning the booting process interruption?

Personal tools

Android USB networking

Add default gateway

route add default gw 192.168.0.200 dev usb0

Wifi Connection on Android

Wifi Wext interface How to tether your G1 Forum wlan configured

Android Compilation

Compiling Your Own G1 Kernel Modules

Android porting

port on real device Android toolchain

Tips and Trick

Mount Android fs rw mode

wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf

Decompiling lib file (*.so)

dpkg -S /path/filename.so strings /path/filename.so Add find command

Openmoko Emulator Setup

OS: Ubuntu 8.10

We run the following commands:

sudo apt-get install monotone git-core git-svn git-email \ git-cvs git-arch gitk python-dev ccache m4 sed bison make cvs gawk \ libc6-dev g++ subversion sharutils docbook openjade quilt libmpfr-dev \ libpcre3-dev texinfo texi2html libboost-date-time-dev libboost-filesystem-dev \ libboost-regex-dev libboost-test-dev libboost-dev zlib1g-dev build-essential \ dh-make debhelper devscripts gcc-3.4 lynx netpbm libsdl1.2-dev dosfstools \ help2man python-psyco lynx

mkdir openmoko

cd openmoko

wget http://www.rwhitby.net/files/openmoko/Makefile

make qemu

The emulator is opened. After splash screen the Boot menu appears. By choosing the "Boot" item the following messages are printed and booting process is interrupted:

  Booting kernel from Legacy Image at 30100000 ...
  Image Name:   openmoko/2.6.24-oe5+gitrfb42ce67
  Created:      2009-02-15   3:19:24 UTC
  Image Type:   ARM Linux Kernel Image (uncompressed)
  Data Size:    1914900 Bytes =  1.8 MB
  Load Address: 30008000
  Entry Point:  30008000
  Verifying Checksum ... OK
  Loading Kernel Image ...


We tried to launch the Emulator with different values of the following parameters specified in build/qemu/openmoko/env file, but it didn't help. For instance:

kernel_wildcard="uImage-2.6.28-oe1+gitr34240a1c06ae36180dee695aa25bbae869b2aa26-r3-om-gta01.bin" rootfs_wildcard="openmoko-fso-image-nox-glibc-ipk--20090216-om-gta01.rootfs.jffs2" uboot_wildcard="u-boot-gta01bv4-1.3.1+gitr650149a53dbdd48bf6dfef90930c8ab182adb512-r1.bin"

download_dir="http://downloads.openmoko.org/distro/unstable/daily/om-gta01/20090216/"


Does anyone have any idea how to fix the problem concerning the booting process interruption?