User:Kestas

From Openmoko

Revision as of 19:33, 10 June 2011 by Kestas (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Random notes...

Contents

Status

QtMoko v31

  • qi-31.udfu
  • uImage-v31.bin
  • qtmoko-debian-v31.ubi

SDcard

After few ext2 filesystem failures on SDcard, decided to give ext4 a try. Fresh ext4 filesystem (created with default parameters) can't be mounted:

EXT4-fs (mmcblk0p1): Filesystem with huge files cannot be mounted RDWR without CONFIG_LBDAF

Fix http://www.nicolaskuttler.com/post/filesystem-with-huge-files-cannot-be-mounted-read-write-without-config_lbdaf/:

tune2fs -O ^huge_file /dev/mmcblk0p1
fsck /dev/mmcblk0p1

Issues v31

Fast battery drain (maybe the same as http://bugs.qtmoko.org/view.php?id=200).

Issues v19

Neo dosn't wake up on alarm
RTC is not updated to system time (Setting Date and Time):
# echo -e "W\n" > /var/spool/at/trigger

Or:

# hwclock --show
Cannot access the Hardware Clock via any known method.
Use the --debug option to see the details of our search for an access method.
# fuser /dev/rtc0
/dev/rtc0:            3269
# ps -fp 3269
UID        PID  PPID  C STIME TTY          TIME CMD
root      3269     1  0 01:56 ?        00:00:00 atd /var/spool/at
# kill 3269
# hwclock --show                                       
Sat Jan  1 08:35:07 2000  -0.142318 seconds
# hwclock --systohc
# hwclock --show
Sun Feb 21 01:35:55 2010  -0.137826 seconds
# . /opt/qtmoko/qpe.env
# atd /var/spool/at
No messages received after dealing operator service codes ( like *113# )
update GSM firmware to moko11 ( GSM/Flashing )
Stop log daemons (until next reboot)
# /etc/init.d/klogd stop
# /etc/init.d/sysklogd stop
Enable AtChat logging (AT commands log)
edit /opt/qtmoko/etc/default/Trolltech/Log.conf, set Enabled=1 in AtChat section
restart QtMoko
# tail -f /var/log/messages
Personal tools

Random notes...

Status

QtMoko v31

  • qi-31.udfu
  • uImage-v31.bin
  • qtmoko-debian-v31.ubi

SDcard

After few ext2 filesystem failures on SDcard, decided to give ext4 a try. Fresh ext4 filesystem (created with default parameters) can't be mounted:

EXT4-fs (mmcblk0p1): Filesystem with huge files cannot be mounted RDWR without CONFIG_LBDAF

Fix http://www.nicolaskuttler.com/post/filesystem-with-huge-files-cannot-be-mounted-read-write-without-config_lbdaf/:

tune2fs -O ^huge_file /dev/mmcblk0p1
fsck /dev/mmcblk0p1

Issues v31

Fast battery drain (maybe the same as http://bugs.qtmoko.org/view.php?id=200).

Issues v19

Neo dosn't wake up on alarm
RTC is not updated to system time (Setting Date and Time):
# echo -e "W\n" > /var/spool/at/trigger

Or:

# hwclock --show
Cannot access the Hardware Clock via any known method.
Use the --debug option to see the details of our search for an access method.
# fuser /dev/rtc0
/dev/rtc0:            3269
# ps -fp 3269
UID        PID  PPID  C STIME TTY          TIME CMD
root      3269     1  0 01:56 ?        00:00:00 atd /var/spool/at
# kill 3269
# hwclock --show                                       
Sat Jan  1 08:35:07 2000  -0.142318 seconds
# hwclock --systohc
# hwclock --show
Sun Feb 21 01:35:55 2010  -0.137826 seconds
# . /opt/qtmoko/qpe.env
# atd /var/spool/at
No messages received after dealing operator service codes ( like *113# )
update GSM firmware to moko11 ( GSM/Flashing )
Stop log daemons (until next reboot)
# /etc/init.d/klogd stop
# /etc/init.d/sysklogd stop
Enable AtChat logging (AT commands log)
edit /opt/qtmoko/etc/default/Trolltech/Log.conf, set Enabled=1 in AtChat section
restart QtMoko
# tail -f /var/log/messages