User:Dcorking

From Openmoko

(Difference between revisions)
Jump to: navigation, search
(Monday, August 20, 2007: typo)
m (Broken link removed.)
 
(2 intermediate revisions by one user not shown)
Line 1: Line 1:
 
I am David Corking.
 
I am David Corking.
  
I have a [[P1 Owners|P1]] device.
+
I have a P1 device.
  
 
*  IRC: irc.freenode.net #openmoko (nick: dcorking)  
 
*  IRC: irc.freenode.net #openmoko (nick: dcorking)  
Line 12: Line 12:
  
 
==Openmoko diary (most recent first) ==
 
==Openmoko diary (most recent first) ==
 +
 +
===Friday, August 24, 2007===
 +
 +
Played (games) a bit with the new UI.  Very impressive.  It needs a few tweaks which I should write up in bugzilla as enhancement requests.  Some nice semi-hidden features:
 +
 +
* Press {{aux}} to return to Today
 +
* Press and hold {{aux}} to open Dialer
 +
* Press and hold {{power}} to get a pop-up menu that includes not only power settings, but screenshot, and landscape orientation
 +
* Flick scroll in Today application launcher and open applications menu.  Tap and hold to stop scrolling.  Scrolling is very clumsy with fingertips, but great with a stylus.
 +
* In Dialer, press and hold '*' to get '+'
 +
 +
Today's tips:
 +
* <tt>mrxvt</tt> does not open the new on screen keyboard.  Instead, open Input Manager from the Applications menu, and tap the white target in the panel
 +
* If using Terminal in [[Mac OS X]] to control the U-Boot command line, don't copy and paste: it seems to paste strange characters into the console, and causes the session to lock up.
 +
 +
I got the panel to crash - but I have forgotten how I did it.
 +
 +
I have had ''no sound'' all day today, despite several reboots.  Only unusual thing was first few boots today were without a USB power source&mdash;hard to image that is the cause, especially as it is tethered to the laptop now, and still no sound.  By no sound, I mean no GUI sound effects, and <tt>madplay</tt> is not working.
  
 
===Thursday, August 23, 2007===
 
===Thursday, August 23, 2007===

Latest revision as of 13:44, 9 September 2008

I am David Corking.

I have a P1 device.

  • IRC: irc.freenode.net #openmoko (nick: dcorking)

Contents

[edit] Openmoko diary (most recent first)

[edit] Friday, August 24, 2007

Played (games) a bit with the new UI. Very impressive. It needs a few tweaks which I should write up in bugzilla as enhancement requests. Some nice semi-hidden features:

  • Press AUX Button to return to Today
  • Press and hold AUX Button to open Dialer
  • Press and hold POWER to get a pop-up menu that includes not only power settings, but screenshot, and landscape orientation
  • Flick scroll in Today application launcher and open applications menu. Tap and hold to stop scrolling. Scrolling is very clumsy with fingertips, but great with a stylus.
  • In Dialer, press and hold '*' to get '+'

Today's tips:

  • mrxvt does not open the new on screen keyboard. Instead, open Input Manager from the Applications menu, and tap the white target in the panel
  • If using Terminal in Mac OS X to control the U-Boot command line, don't copy and paste: it seems to paste strange characters into the console, and causes the session to lock up.

I got the panel to crash - but I have forgotten how I did it.

I have had no sound all day today, despite several reboots. Only unusual thing was first few boots today were without a USB power source—hard to image that is the cause, especially as it is tethered to the laptop now, and still no sound. By no sound, I mean no GUI sound effects, and madplay is not working.

[edit] Thursday, August 23, 2007

Got Terminal.app to talk to the U-Boot console. This will be useful for setting kernel boot parameters, and also for erasing the rootfs flash partition. Wrote it up at Mac OS X#USB Serial with Terminal.

[edit] Wednesday, August 22, 2007

Headset jack does not accept a standard 3.5 mm headset or iPod dock plug. Need to make an adapter to play podcasts or use hands-free in my car.

The battery icon is showing around 70% charged, even though it ought to be fully charged.

cat /sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/battvolt
3843

UI (tap feedback) sounds come from the headset and the speaker.

Managed to cause the headset (but not the speaker) to make weird phone-related noises by using the new Dialer. Closing the dialer didn't stop it. Fiddling with the new Today app and dialer, I managed to cause X and gsmd to crash. On IRC, DPThought told me that gsmd is broken in the snapshot, but so hhf423 recommended I use ipkg.
dcorking: if you do the ipkg update etc. with that .08 release, gsmd gets somewhat more stable, but audio switching still does not work
Also on IRC, I read about nice screenshots of the new GUI:

Did not need to reboot to recover from the crash.

cd /etc/init.d/
./xserver-nodm start

was sufficient to restart X, the matchbox desktop and openmoko-today application.

Reproduced the madplay crash - here is the console output immediately after the crash:

root@fic-gta01:/media/card$ madplay -v 02--Symphony\ No\ 9\ in\ D\ Minor\ Op\ 125_\ Allegro\ ma\ non\ troppo--Philharmonia\ Baroque\ Orchestra-lofi.mp3 
MPEG Audio Decoder 0.15.2 (beta) - Copyright (C) 2000-2004 Robert Leslie et al.
         Title: Symphony No 9 in D Minor Op 12
        Artist: Philharmonia Baroque Orchestra
         Album: Beethoven - Opferlied and Symp
         Track: 2
          Year: 2007
         Genre: Classical
       Comment: www.magnatune.com/artists/pbo
 00:01:34 Layer III, 32 kbps, 22050 Hz, single channel, no CRC
3604 frames decoded (0:01:34.1), -9.4 dB peak amplitude, 0 clipped samples
root@fic-gta01:/media/card$

Turns out the problem was that the music file got truncated in transfer. There seems to be trouble writing data quickly (that is at USB 1.1 speeds) to the microSD card: Bugzilla Bug 677 - I/O errors on heavy microSD writes

[edit] Tuesday, August 21, 2007

Played a 15 minute low bit rate MP3 on microSD card through the speaker (madplay controlled via screens under ssh). It seemed to die after 3 or 4 minutes, but works ok on desktop iTunes.

Flashed to 2007.2 snapshot - this has the new finger-oriented GUI from OpenedHand:

Looks great.

[edit] Monday, August 20, 2007

Device is working beautifully, tethered to my MacBook by USB.

There is a new graphic for battery status - it looks like an empty battery, with a pronged cable plugged into it. I don't know if this means 'charging', or 'fully charged', or something else.

Remote terminal by ssh from the MacBook into the Neo worked first time - it is a bit disconcerting to have an IP login with no password, but great to have a fully functioning Linux console, in a computer that is as powerful as my first Linux desktop system 9 years ago (bar hardware screen acceleration.)

Despite the speed and storage of the system, most of the common unix utilities come from the cut down BusyBox toolkit, rather than the more functional GNU utilities.

Read that AUX wakes up the screen when it has gone to sleep. When in Linux, press and hold for 5 seconds to get a stylus menu including 'power off'. Press and hold for 9 seconds otherwise to halt.

I helped tidy up the openmoko wiki.

I ran gedit remotely from the Mac (using the Neo as the X server, with instructions on USB Networking#Remote apps on neo) It looked remarkably good and was responsive to the stylus and the on-screen keyboard.

When I flashed this image on Saturday, I calibrated the touchscreen with my fingernail. Unfortunately I was often missing targets by a few pixels, so thanks to Graham Williams's survivor website , I found that I could run ts_calibrate from the command line, this time with the stylus, and after 5 taps, things were working much better!

[edit] Sunday, August 19, 2007

The screen is blank - nothing was happening! So I tested briefly with a BL-5C battery from my Nokia phone. I wanted to put the FIC battery in the Nokia phone to charge, but it is much thicker than the BL-5C, so the Nokia phone cover does not go back on.

Charged my deeply discharged device for most of the day with the dumb APC charger. Then, still connected to the charger, I booted and played with the UI and the stylus. The battery indicator showed a little over half full, but very quickly discharged, showing red and then shutting down.

I plugged into the MacBook (which is configured not to sleep) and left it overnight.

[edit] Saturday August 18, 2007

Briefly tested the new P1 device with a charged Nokia BL-5C battery

Put the FIC battery in the phone, and charged for approx. 8 hours with an APC dumb USB charger. Surprised to see that the phone boots as soon as power is applied to the USB socket (this is as designed.)

Installed AJZaurusUSB and OpenMoko Flasher on my Mac OS X Intel MacBook. Discovered that the Neo1973 IR port was in fact the AUX button (no IR - as designed.) Flashed the device with a recent kernel and rootfs.

  • openmoko-devel-image-fic-gta01-20070803091138.rootfs.jffs2
  • uImage-2.6.21.6-moko11-r1_0_0_2388_-fic-gta01.bin

(the image I first wanted did not seem to be visible to OpenMoko Flasher, so I decided not to swim upstream, and tried another one instead.)

Booted into an attractive high resolution graphical interface.

Pressed the power button, the screen went blank. I didn't know if it was powered off—it turns out it wasn't, and it deeply discharged the battery overnight.

END

Personal tools

I am David Corking.

I have a P1 device.

  • IRC: irc.freenode.net #openmoko (nick: dcorking)

Openmoko diary (most recent first)

Thursday, August 23, 2007

Got Terminal.app to talk to the U-Boot console. This will be useful for setting kernel boot parameters, and also for erasing the rootfs flash partition. Wrote it up at Mac OS X#USB Serial with Terminal.

Wednesday, August 22, 2007

Headset jack does not accept a standard 3.5 mm headset or iPod dock plug. Need to make an adapter to play podcasts or use hands-free in my car.

The battery icon is showing around 70% charged, even though it ought to be fully charged.

cat /sys/devices/platform/s3c2410-i2c/i2c-0/0-0008/battvolt
3843

UI (tap feedback) sounds come from the headset and the speaker.

Managed to cause the headset (but not the speaker) to make weird phone-related noises by using the new Dialer. Closing the dialer didn't stop it. Fiddling with the new Today app and dialer, I managed to cause X and gsmd to crash. On IRC, DPThought told me that gsmd is broken in the snapshot, but so hhf423 recommended I use ipkg.
dcorking: if you do the ipkg update etc. with that .08 release, gsmd gets somewhat more stable, but audio switching still does not work
Also on IRC, I read about nice screenshots of the new GUI:

Did not need to reboot to recover from the crash.

cd /etc/init.d/
./xserver-nodm start

was sufficient to restart X, the matchbox desktop and openmoko-today application.

Reproduced the madplay crash - here is the console output immediately after the crash:

root@fic-gta01:/media/card$ madplay -v 02--Symphony\ No\ 9\ in\ D\ Minor\ Op\ 125_\ Allegro\ ma\ non\ troppo--Philharmonia\ Baroque\ Orchestra-lofi.mp3 
MPEG Audio Decoder 0.15.2 (beta) - Copyright (C) 2000-2004 Robert Leslie et al.
         Title: Symphony No 9 in D Minor Op 12
        Artist: Philharmonia Baroque Orchestra
         Album: Beethoven - Opferlied and Symp
         Track: 2
          Year: 2007
         Genre: Classical
       Comment: www.magnatune.com/artists/pbo
 00:01:34 Layer III, 32 kbps, 22050 Hz, single channel, no CRC
3604 frames decoded (0:01:34.1), -9.4 dB peak amplitude, 0 clipped samples
root@fic-gta01:/media/card$

Turns out the problem was that the music file got truncated in transfer. There seems to be trouble writing data quickly (that is at USB 1.1 speeds) to the microSD card: Bugzilla Bug 677 - I/O errors on heavy microSD writes

Tuesday, August 21, 2007

Played a 15 minute low bit rate MP3 on microSD card through the speaker (madplay controlled via screens under ssh). It seemed to die after 3 or 4 minutes, but works ok on desktop iTunes.

Flashed to 2007.2 snapshot - this has the new finger-oriented GUI from OpenedHand:

Looks great.

Monday, August 20, 2007

Device is working beautifully, tethered to my MacBook by USB.

There is a new graphic for battery status - it looks like an empty battery, with a pronged cable plugged into it. I don't know if this means 'charging', or 'fully charged', or something else.

Remote terminal by ssh from the MacBook into the Neo worked first time - it is a bit disconcerting to have an IP login with no password, but great to have a fully functioning Linux console, in a computer that is as powerful as my first Linux desktop system 9 years ago (bar hardware screen acceleration.)

Despite the speed and storage of the system, most of the common unix utilities come from the cut down BusyBox toolkit, rather than the more functional GNU utilities.

Read that AUX wakes up the screen when it has gone to sleep. When in Linux, press and hold for 5 seconds to get a stylus menu including 'power off'. Press and hold for 9 seconds otherwise to halt.

I helped tidy up the openmoko wiki.

I ran gedit remotely from the Mac (using the Neo as the X server, with instructions on USB Networking#Remote apps on neo) It looked remarkably good and was responsive to the stylus and the on-screen keyboard.

When I flashed this image on Saturday, I calibrated the touchscreen with my fingernail. Unfortunately I was often missing targets by a few pixels, so thanks to Graham Williams's survivor website , I found that I could run ts_calibrate from the command line, this time with the stylus, and after 5 taps, things were working much better!

Sunday, August 19, 2007

The screen is blank - nothing was happening! So I tested briefly with a BL-5C battery from my Nokia phone. I wanted to put the FIC battery in the Nokia phone to charge, but it is much thicker than the BL-5C, so the Nokia phone cover does not go back on.

Charged my deeply discharged device for most of the day with the dumb APC charger. Then, still connected to the charger, I booted and played with the UI and the stylus. The battery indicator showed a little over half full, but very quickly discharged, showing red and then shutting down.

I plugged into the MacBook (which is configured not to sleep) and left it overnight.

Saturday August 18, 2007

Briefly tested the new P1 device with a charged Nokia BL-5C battery

Put the FIC battery in the phone, and charged for approx. 8 hours with an APC dumb USB charger. Surprised to see that the phone boots as soon as power is applied to the USB socket (this is as designed.)

Installed AJZaurusUSB and OpenMoko Flasher on my Mac OS X Intel MacBook. Discovered that the Neo1973 IR port was in fact the AUX button (no IR - as designed.) Flashed the device with a recent kernel and rootfs.

  • openmoko-devel-image-fic-gta01-20070803091138.rootfs.jffs2
  • uImage-2.6.21.6-moko11-r1_0_0_2388_-fic-gta01.bin

(the image I first wanted did not seem to be visible to OpenMoko Flasher, so I decided not to swim upstream, and tried another one instead.)

Booted into an attractive high resolution graphical interface.

Pressed the power button, the screen went blank. I didn't know if it was powered off—it turns out it wasn't, and it deeply discharged the battery overnight.

END