User:Archimedes

From Openmoko

(Difference between revisions)
Jump to: navigation, search
Line 1: Line 1:
 
==linphone==
 
==linphone==
 
I have build linphone and dependencies (libosip2, libexosip2, speex) for the freerunner.
 
I have build linphone and dependencies (libosip2, libexosip2, speex) for the freerunner.
Status: Not usable (no sound yet, segfault in preferences)
+
Now it could even work, after Michael send me a small notice. See OSS workaround.
  
 
===Get it===
 
===Get it===
 
You can get my packages here:<br>
 
You can get my packages here:<br>
http://freerunner.archimedes.mobi/builds/ (DOES NOT WORK YET!)
+
http://freerunner.archimedes.mobi/builds/ (SEEMS TO WORK WITH OSS.)
  
 
Installorder: libosip2, libexosip2, speex, linphone (you need angstrom (quite sure) and celtune (maybe) as additional repositories. Look at [[Distributions]] on how to set them up).
 
Installorder: libosip2, libexosip2, speex, linphone (you need angstrom (quite sure) and celtune (maybe) as additional repositories. Look at [[Distributions]] on how to set them up).
  
 
===Status===
 
===Status===
* Rebuild om0 still segfaults, reported upstream (
+
* Rebuild om0 still segfaults, reported upstream. But no response...
 +
* Rebuild om0 could work with OSS workaround.
  
 
===What works===
 
===What works===
 
*Installing
 
*Installing
*Making a direct sip call
+
*Don't know, possibly everything using OSS workaround.
*answering a direct sip call
+
  
 
===What does NOT work===
 
===What does NOT work===
*Preferences segfault, no dbg build for gdb yet
+
*Don't know, possibly everything using OSS workaround.
*Exit segfaults (really need a dbg build!)
+
*Hearing each other (maybe need preferences? :-D)
+
  
 
===Todo===
 
===Todo===
*Need to create -dev-Builds
+
*Make linphone use alsa if possible.
*Need to create -dbg-Builds (!)
+
*Find out how to turn on mic/speaker (alsamixer, select device in linphone - not possible because of segfaults)
+
 
*Clean up the packages (remove man-pages,...)
 
*Clean up the packages (remove man-pages,...)
  
Line 35: Line 31:
  
 
This is my first build for OpenMoko, even my first crosscompilation ever. Have Fun.
 
This is my first build for OpenMoko, even my first crosscompilation ever. Have Fun.
 +
 +
===OSS Workaround===
 +
Michael (don't know his OM username) send me this E-Mail:
 +
 +
Hello,
 +
 +
I looked at your openmoko site and installed the linphone packets.
 +
They segfault as you describe.
 +
You combiled linphone only with OSS-support but without alsa.
 +
No sound card is detected in linphone because the device files
 +
/dev/dsp does not exist. Linphone handles that case not correctly.
 +
 +
With "modprobe snd-pcm-oss" and "modprobe snd-mixer-oss"
 +
linephone does no more segfault.
 +
 +
Hope it helps.
 +
 +
Michael
 +
 +
I didn't test this, but it sounds ok.
 +
Thanks Michael :-)
 +
 +
I believe that though I used --enable-alsa linphone also did --enable-oss on itself, which causes this error. I'll try to make a new build using --disable-oss (or the like) to fix this bug as soon as I find some free time (which might be in about a month, in the end of August. Stupid theory exams... or stupid me... still have to figure it out... well...)
  
 
===./configure===
 
===./configure===

Revision as of 09:53, 20 September 2008

Contents

linphone

I have build linphone and dependencies (libosip2, libexosip2, speex) for the freerunner. Now it could even work, after Michael send me a small notice. See OSS workaround.

Get it

You can get my packages here:
http://freerunner.archimedes.mobi/builds/ (SEEMS TO WORK WITH OSS.)

Installorder: libosip2, libexosip2, speex, linphone (you need angstrom (quite sure) and celtune (maybe) as additional repositories. Look at Distributions on how to set them up).

Status

  • Rebuild om0 still segfaults, reported upstream. But no response...
  • Rebuild om0 could work with OSS workaround.

What works

  • Installing
  • Don't know, possibly everything using OSS workaround.

What does NOT work

  • Don't know, possibly everything using OSS workaround.

Todo

  • Make linphone use alsa if possible.
  • Clean up the packages (remove man-pages,...)

Notes

I had to recompile speex because linphone did not compile with the angstrom version (speex_1.1.12+1.2beta1-r1_armv4t), but maybe you only have to setup a softlink for it to work (start linphone by shell, like DISPLAY=:0 linphone).

After a segfault do killall mediaserver ;-)

This is my first build for OpenMoko, even my first crosscompilation ever. Have Fun.

OSS Workaround

Michael (don't know his OM username) send me this E-Mail:

Hello,

I looked at your openmoko site and installed the linphone packets.
They segfault as you describe.
You combiled linphone only with OSS-support but without alsa.
No sound card is detected in linphone because the device files
/dev/dsp does not exist. Linphone handles that case not correctly.

With "modprobe snd-pcm-oss" and "modprobe snd-mixer-oss"
linephone does no more segfault.

Hope it helps.

Michael 

I didn't test this, but it sounds ok. Thanks Michael :-)

I believe that though I used --enable-alsa linphone also did --enable-oss on itself, which causes this error. I'll try to make a new build using --disable-oss (or the like) to fix this bug as soon as I find some free time (which might be in about a month, in the end of August. Stupid theory exams... or stupid me... still have to figure it out... well...)

./configure

linphone:

export ARM_INSTALL_TREE=/usr/local/openmoko/arm/arm-angstrom-linux-gnueabi
./configure --prefix=/usr --host=arm-linux --with-gnu-ld --disable-static \
--disable-glib --with-osip=$ARM_INSTALL_TREE/usr \
--with-readline=$ARM_INSTALL_TREE/usr \
SPEEX_CFLAGS="-I$ARM_INSTALL_TREE/usr/include" \
SPEEX_LIBS="-L$ARM_INSTALL_TREE/usr/lib -lspeex " \
--enable-ipv6 --disable-video --enable-alsa

speex:

./configure --prefix=/usr --host=arm-linux --with-gnu-ld --disable-static --enable-fixed-point --enable-arm-asm

libosip2:

./configure --prefix=/usr --host=arm-linux --with-gnu-ld --disable-static

libexosip2:

./configure --prefix=/usr --host=arm-linux --with-gnu-ld --disable-static
Personal tools

linphone

I have build linphone and dependencies (libosip2, libexosip2, speex) for the freerunner. Now it could even work, after Michael send me a small notice. See OSS workaround.

Get it

You can get my packages here:
http://freerunner.archimedes.mobi/builds/ (SEEMS TO WORK WITH OSS.)

Installorder: libosip2, libexosip2, speex, linphone (you need angstrom (quite sure) and celtune (maybe) as additional repositories. Look at Distributions on how to set them up).

Status

  • Rebuild om0 still segfaults, reported upstream. But no response...
  • Rebuild om0 could work with OSS workaround.

What works

  • Installing
  • Don't know, possibly everything using OSS workaround.

What does NOT work

  • Don't know, possibly everything using OSS workaround.

Todo

  • Make linphone use alsa if possible.
  • Clean up the packages (remove man-pages,...)

Notes

I had to recompile speex because linphone did not compile with the angstrom version (speex_1.1.12+1.2beta1-r1_armv4t), but maybe you only have to setup a softlink for it to work (start linphone by shell, like DISPLAY=:0 linphone).

After a segfault do killall mediaserver ;-)

This is my first build for OpenMoko, even my first crosscompilation ever. Have Fun.

OSS Workaround

Michael (don't know his OM username) send me this E-Mail:

Hello,

I looked at your openmoko site and installed the linphone packets.
They segfault as you describe.
You combiled linphone only with OSS-support but without alsa.
No sound card is detected in linphone because the device files
/dev/dsp does not exist. Linphone handles that case not correctly.

With "modprobe snd-pcm-oss" and "modprobe snd-mixer-oss"
linephone does no more segfault.

Hope it helps.

Michael 

I didn't test this, but it sounds ok. Thanks Michael :-)

I believe that though I used --enable-alsa linphone also did --enable-oss on itself, which causes this error. I'll try to make a new build using --disable-oss (or the like) to fix this bug as soon as I find some free time (which might be in about a month, in the end of August. Stupid theory exams... or stupid me... still have to figure it out... well...)

./configure

linphone:

export ARM_INSTALL_TREE=/usr/local/openmoko/arm/arm-angstrom-linux-gnueabi
./configure --prefix=/usr --host=arm-linux --with-gnu-ld --disable-static \
--disable-glib --with-osip=$ARM_INSTALL_TREE/usr \
--with-readline=$ARM_INSTALL_TREE/usr \
SPEEX_CFLAGS="-I$ARM_INSTALL_TREE/usr/include" \
SPEEX_LIBS="-L$ARM_INSTALL_TREE/usr/lib -lspeex " \
--enable-ipv6 --disable-video --enable-alsa

speex:

./configure --prefix=/usr --host=arm-linux --with-gnu-ld --disable-static --enable-fixed-point --enable-arm-asm

libosip2:

./configure --prefix=/usr --host=arm-linux --with-gnu-ld --disable-static

libexosip2:

./configure --prefix=/usr --host=arm-linux --with-gnu-ld --disable-static