Talk:Qtopia / Qt Extended on FreeRunner

From Openmoko

(Difference between revisions)
Jump to: navigation, search
(Browser?)
(TangoGPS)
Line 51: Line 51:
 
==TangoGPS==
 
==TangoGPS==
 
Is tangogps supposed to work with qtextended? wasn't it a gtk-app, was it?
 
Is tangogps supposed to work with qtextended? wasn't it a gtk-app, was it?
 +
 +
:tangoGPS will not work with QtExtended 4.4.2 image, at least there are package dependency problems
 +
 +
<nowiki>
 +
root@om-gta02:~# opkg -noaction install http://www.tangogps.org/downloads/tangogps_0.9.3-r1_armv4t.ipk
 +
Downloading http://www.tangogps.org/downloads/tangogps_0.9.3-r1_armv4t.ipk
 +
Installing tangogps (0.9.3-r1) to root...
 +
Collected errors:
 +
* ERROR: Cannot satisfy the following dependencies for tangogps:
 +
        *  gtk+
 +
        *  gtk+-fastscaling (>= 2.10.14)
 +
        *  libatk-1.0-0 (>= 1.20.0)
 +
        *  libxext6 (>= 1.0.3)
 +
        *  libxcursor1 (>= 1.1.8)
 +
        *  libxfixes3 (>= 4.0.3)
 +
        *  pango (>= 1.18.3)
 +
        *  libcairo2 (>= 1.4.10)
 +
        *  libfontconfig1 (>= 2.4.1)
 +
        *  libfreetype6 (>= 2.3.5)
 +
        *  libxrender1 (>= 0.9.2)
 +
        *  libx11-6 (>= 1.1.2)
 +
        *  libxau6 (>= 1.0.3)
 +
        *  libxdmcp6 (>= 1.0.2)
 +
        *  gconf-dbus (>= 2.16.0+svnr641)
 +
</nowiki>
 +
:TangoGPS depends upon libx11, therefor tangoGPS is unusable without an Xserver (Xserver might be Xfbdev, but QtExtended directly uses the framebuffer), so no luck for tangoGPS on QtExtended :-(
 +
:QtExtended comes with an "Mapping Demo" application

Revision as of 11:15, 22 December 2008

Contents

jffs image

Mounting the jffs file as described did not work for me. Instead I did the following:

mknod /dev/mtdblock0 b 31 0 
losetup /dev/loop0 <rootfs.jffs2 file> 
echo "/dev/loop0" > /sys/module/block2mtd/parameters/block2mtd 
mount -t jffs2 /dev/mtdblock0 <mountpoint> 

This seemed to work out alright.

-russell

Feedback

I had pretty good luck with the procedure on the Qtopia on FreeRunner page using KnoppMyth 5.5 for my linux. Had to su but few problems. The only part I didn't figure out was the -C switch in the tar command. Failed every time. Worked around it.

-Pfloyd


uImage path

A problem I had was with "Installing Kernel" instructions : instead of putting uImage.bin on the first partition in /boot folder, I had to put it directly in / (without that I couldn't boot). If someone else can reproduce the problem, I will edit the article. -Xavier_OM

Same here I have to put uImage directly to / (not to /boot) -PipBoy2000
Same here too. Should I change it on the page? --Nowic 16:24, 7 August 2008 (UTC)


Partitioning & u-boot

How are you all (who have successfully booted to SD) partitioning your cards?

Also, what (if any) changes did you make to u-boot environment? I was unable to make any of my changes stick, so I couldn't add support for ext3.

- russell

Bugtracker

Where should I report Qtopia related bugs? To docs.openmoko.org too? --Nowic 17:02, 10 August 2008 (UTC)

My understanding is that they should be reported to Trolltech. I'll add the tracker address and information to the page now. --JohnSullivan 16:46, 4 September 2008 (UTC)

Suspend/Resume bug

I just tested with 4.3.3, booting on battery power, and the phone suspends and resumes just fine. Is this still reproducible now? I suggest removing it from the page. --JohnSullivan 16:47, 4 September 2008 (UTC)

Browser?

in "Current Status" stands, that their is now browser...but in "What is in the latest release (Qtopia 4.4)? " there stands that a webkit browser is on the image...what is correct?

The Qt Extended 4.4.2 image does contain a webkit based browser. It works just fine, although i would like to see a zooming in/out feature :-)

TangoGPS

Is tangogps supposed to work with qtextended? wasn't it a gtk-app, was it?

tangoGPS will not work with QtExtended 4.4.2 image, at least there are package dependency problems
root@om-gta02:~# opkg -noaction install http://www.tangogps.org/downloads/tangogps_0.9.3-r1_armv4t.ipk
Downloading http://www.tangogps.org/downloads/tangogps_0.9.3-r1_armv4t.ipk
Installing tangogps (0.9.3-r1) to root...
Collected errors:
 * ERROR: Cannot satisfy the following dependencies for tangogps:
         *  gtk+
         *  gtk+-fastscaling (>= 2.10.14)
         *  libatk-1.0-0 (>= 1.20.0)
         *  libxext6 (>= 1.0.3)
         *  libxcursor1 (>= 1.1.8)
         *  libxfixes3 (>= 4.0.3)
         *  pango (>= 1.18.3)
         *  libcairo2 (>= 1.4.10)
         *  libfontconfig1 (>= 2.4.1)
         *  libfreetype6 (>= 2.3.5)
         *  libxrender1 (>= 0.9.2)
         *  libx11-6 (>= 1.1.2)
         *  libxau6 (>= 1.0.3)
         *  libxdmcp6 (>= 1.0.2)
         *  gconf-dbus (>= 2.16.0+svnr641)
 
TangoGPS depends upon libx11, therefor tangoGPS is unusable without an Xserver (Xserver might be Xfbdev, but QtExtended directly uses the framebuffer), so no luck for tangoGPS on QtExtended :-(
QtExtended comes with an "Mapping Demo" application
Personal tools

jffs image

Mounting the jffs file as described did not work for me. Instead I did the following:

mknod /dev/mtdblock0 b 31 0 
losetup /dev/loop0 <rootfs.jffs2 file> 
echo "/dev/loop0" > /sys/module/block2mtd/parameters/block2mtd 
mount -t jffs2 /dev/mtdblock0 <mountpoint> 

This seemed to work out alright.

-russell

Feedback

I had pretty good luck with the procedure on the Qtopia on FreeRunner page using KnoppMyth 5.5 for my linux. Had to su but few problems. The only part I didn't figure out was the -C switch in the tar command. Failed every time. Worked around it.

-Pfloyd


uImage path

A problem I had was with "Installing Kernel" instructions : instead of putting uImage.bin on the first partition in /boot folder, I had to put it directly in / (without that I couldn't boot). If someone else can reproduce the problem, I will edit the article. -Xavier_OM

Same here I have to put uImage directly to / (not to /boot) -PipBoy2000
Same here too. Should I change it on the page? --Nowic 16:24, 7 August 2008 (UTC)


Partitioning & u-boot

How are you all (who have successfully booted to SD) partitioning your cards?

Also, what (if any) changes did you make to u-boot environment? I was unable to make any of my changes stick, so I couldn't add support for ext3.

- russell

Bugtracker

Where should I report Qtopia related bugs? To docs.openmoko.org too? --Nowic 17:02, 10 August 2008 (UTC)

My understanding is that they should be reported to Trolltech. I'll add the tracker address and information to the page now. --JohnSullivan 16:46, 4 September 2008 (UTC)

Suspend/Resume bug

I just tested with 4.3.3, booting on battery power, and the phone suspends and resumes just fine. Is this still reproducible now? I suggest removing it from the page. --JohnSullivan 16:47, 4 September 2008 (UTC)

Browser?

in "Current Status" stands, that their is now browser...but in "What is in the latest release (Qtopia 4.4)? " there stands that a webkit browser is on the image...what is correct?

The Qt Extended 4.4.2 image does contain a webkit based browser. It works just fine, although i would like to see a zooming in/out feature :-)

TangoGPS

Is tangogps supposed to work with qtextended? wasn't it a gtk-app, was it?