Talk:Qtopia / Qt Extended on FreeRunner

From Openmoko

(Difference between revisions)
Jump to: navigation, search
(browser?)
Line 46: Line 46:
 
== Browser? ==
 
== Browser? ==
 
in "Current Status" stands, that their is now browser...but in "What is in the latest release (Qtopia 4.4)? " there stands that a webkit browser is on the image...what is correct?
 
in "Current Status" stands, that their is now browser...but in "What is in the latest release (Qtopia 4.4)? " there stands that a webkit browser is on the image...what is correct?
 +
 +
 +
==TangoGPS==
 +
Is tangogps supposed to work with qtextended? wasn't it a gtk-app, was it?

Revision as of 10:57, 6 November 2008

Contents

jffs image

Mounting the jffs file as described did not work for me. Instead I did the following:

mknod /dev/mtdblock0 b 31 0 
losetup /dev/loop0 <rootfs.jffs2 file> 
echo "/dev/loop0" > /sys/module/block2mtd/parameters/block2mtd 
mount -t jffs2 /dev/mtdblock0 <mountpoint> 

This seemed to work out alright.

-russell

Feedback

I had pretty good luck with the procedure on the Qtopia on FreeRunner page using KnoppMyth 5.5 for my linux. Had to su but few problems. The only part I didn't figure out was the -C switch in the tar command. Failed every time. Worked around it.

-Pfloyd


uImage path

A problem I had was with "Installing Kernel" instructions : instead of putting uImage.bin on the first partition in /boot folder, I had to put it directly in / (without that I couldn't boot). If someone else can reproduce the problem, I will edit the article. -Xavier_OM

Same here I have to put uImage directly to / (not to /boot) -PipBoy2000
Same here too. Should I change it on the page? --Nowic 16:24, 7 August 2008 (UTC)


Partitioning & u-boot

How are you all (who have successfully booted to SD) partitioning your cards?

Also, what (if any) changes did you make to u-boot environment? I was unable to make any of my changes stick, so I couldn't add support for ext3.

- russell

Bugtracker

Where should I report Qtopia related bugs? To docs.openmoko.org too? --Nowic 17:02, 10 August 2008 (UTC)

My understanding is that they should be reported to Trolltech. I'll add the tracker address and information to the page now. --JohnSullivan 16:46, 4 September 2008 (UTC)

Suspend/Resume bug

I just tested with 4.3.3, booting on battery power, and the phone suspends and resumes just fine. Is this still reproducible now? I suggest removing it from the page. --JohnSullivan 16:47, 4 September 2008 (UTC)

Browser?

in "Current Status" stands, that their is now browser...but in "What is in the latest release (Qtopia 4.4)? " there stands that a webkit browser is on the image...what is correct?


TangoGPS

Is tangogps supposed to work with qtextended? wasn't it a gtk-app, was it?

Personal tools

jffs image

Mounting the jffs file as described did not work for me. Instead I did the following:

mknod /dev/mtdblock0 b 31 0 
losetup /dev/loop0 <rootfs.jffs2 file> 
echo "/dev/loop0" > /sys/module/block2mtd/parameters/block2mtd 
mount -t jffs2 /dev/mtdblock0 <mountpoint> 

This seemed to work out alright.

-russell

Feedback

I had pretty good luck with the procedure on the Qtopia on FreeRunner page using KnoppMyth 5.5 for my linux. Had to su but few problems. The only part I didn't figure out was the -C switch in the tar command. Failed every time. Worked around it.

-Pfloyd


uImage path

A problem I had was with "Installing Kernel" instructions : instead of putting uImage.bin on the first partition in /boot folder, I had to put it directly in / (without that I couldn't boot). If someone else can reproduce the problem, I will edit the article. -Xavier_OM

Same here I have to put uImage directly to / (not to /boot) -PipBoy2000
Same here too. Should I change it on the page? --Nowic 16:24, 7 August 2008 (UTC)


Partitioning & u-boot

How are you all (who have successfully booted to SD) partitioning your cards?

Also, what (if any) changes did you make to u-boot environment? I was unable to make any of my changes stick, so I couldn't add support for ext3.

- russell

Bugtracker

Where should I report Qtopia related bugs? To docs.openmoko.org too? --Nowic 17:02, 10 August 2008 (UTC)

My understanding is that they should be reported to Trolltech. I'll add the tracker address and information to the page now. --JohnSullivan 16:46, 4 September 2008 (UTC)

Suspend/Resume bug

I just tested with 4.3.3, booting on battery power, and the phone suspends and resumes just fine. Is this still reproducible now? I suggest removing it from the page. --JohnSullivan 16:47, 4 September 2008 (UTC)

Browser?

in "Current Status" stands, that their is now browser...but in "What is in the latest release (Qtopia 4.4)? " there stands that a webkit browser is on the image...what is correct?