Talk:Neovento

From Openmoko

(Difference between revisions)
Jump to: navigation, search
m (Talk:Fyp moved to Talk:Neovento: name change)
(moved todo to discussion)
Line 24: Line 24:
  
 
GPS works in 3.18 --[[User:Rakshat|Rakshat]] 12:34, 23 March 2009 (UTC)
 
GPS works in 3.18 --[[User:Rakshat|Rakshat]] 12:34, 23 March 2009 (UTC)
 +
 +
= To-Do =
 +
 +
Please help in contributing Neovento changes back to Debian. It does not help the big picture to do just concentrate on images and scripts if the base work in Debian does not improve - the development in the long run suffers.
 +
 +
* Contribute packaging to [http://wiki.debian.org/Teams/DebianFSO pkg-fso] team for any packages not yet in the repositories (already in Debian or Debian's PKG-FSO: Pidgin, mokomaze, tangogps, epdfview)
 +
** Fennec
 +
** Wifi-radar
 +
** Mokomaze
 +
* Contribute changes to Debian or upstream repositories
 +
** Zhone
 +
** LXDE (eg. lxde-fso package with settings)
 +
** Matchbox
 +
* Create for example "fso-neoventa" meta package for PKG-FSO repositories, installation of which equals to installing Neovento image
 +
 +
Note that especially contributing to Debian-FSO team's work is not that hard, and not all requirements of official Debian apply there.
 +
 +
>>>> I thought about that some time ago, but recently had not the time to do things like that. I will think about it again after the next release.

Revision as of 17:50, 30 April 2009

Getting wi-fi working

I had some issues here.

1) My ethernet driver was eth1 (not wlan0 or eth0).

2) wifi-radar requires manually setting up wpa_supplicant at /etc/wpa_supplicant.conf

--Dfsmith 11:53, 23 February 2009 (UTC)

No fix in GPS

I am not able to get any GPS fix on either Zhone or Tango GPS though the GPS indicator on the top panel is on. At the same place i am getting fix on 2008.12. Do i need to manually switch something on? --Rakshat 13:02, 19 March 2009 (UTC)

Do you use fyp 3.18 and the recommended kernel? Which bootloader? It should really work, it's confirmed by quite a lot of people. But please explain your problem. neovento

I have fyp 3.01 and recommended kernel. QI bootloader. Should i be using the latest U-Boot (I think I read that somewhere)? I did not make a swap file. I will try again with 3.18 tomorrow and report.--Rakshat 14:39, 19 March 2009 (UTC)

Just flash 3.18 (and new kernel), GPS will work then. It also works really good with Qi.neovento

GPS works in 3.18 --Rakshat 12:34, 23 March 2009 (UTC)

To-Do

Please help in contributing Neovento changes back to Debian. It does not help the big picture to do just concentrate on images and scripts if the base work in Debian does not improve - the development in the long run suffers.

  • Contribute packaging to pkg-fso team for any packages not yet in the repositories (already in Debian or Debian's PKG-FSO: Pidgin, mokomaze, tangogps, epdfview)
    • Fennec
    • Wifi-radar
    • Mokomaze
  • Contribute changes to Debian or upstream repositories
    • Zhone
    • LXDE (eg. lxde-fso package with settings)
    • Matchbox
  • Create for example "fso-neoventa" meta package for PKG-FSO repositories, installation of which equals to installing Neovento image

Note that especially contributing to Debian-FSO team's work is not that hard, and not all requirements of official Debian apply there.

>>>> I thought about that some time ago, but recently had not the time to do things like that. I will think about it again after the next release.

Personal tools

Getting wi-fi working

I had some issues here.

1) My ethernet driver was eth1 (not wlan0 or eth0).

2) wifi-radar requires manually setting up wpa_supplicant at /etc/wpa_supplicant.conf

--Dfsmith 11:53, 23 February 2009 (UTC)

No fix in GPS

I am not able to get any GPS fix on either Zhone or Tango GPS though the GPS indicator on the top panel is on. At the same place i am getting fix on 2008.12. Do i need to manually switch something on? --Rakshat 13:02, 19 March 2009 (UTC)

Do you use fyp 3.18 and the recommended kernel? Which bootloader? It should really work, it's confirmed by quite a lot of people. But please explain your problem. neovento

I have fyp 3.01 and recommended kernel. QI bootloader. Should i be using the latest U-Boot (I think I read that somewhere)? I did not make a swap file. I will try again with 3.18 tomorrow and report.--Rakshat 14:39, 19 March 2009 (UTC)

Just flash 3.18 (and new kernel), GPS will work then. It also works really good with Qi.neovento

GPS works in 3.18 --Rakshat 12:34, 23 March 2009 (UTC)