Talk:Manual Debian

From Openmoko

Revision as of 09:35, 22 August 2008 by Dbmoodb (Talk | contribs)

Jump to: navigation, search

Contents

Booting

Umount

I remember seeing a umount /media/card command on this page which i don't see anymore. That's needed or you will get

/dev/mmcblk0p1 is mounted; will not make a filesystem here!

Fdisk will also complain

WARNING: rereading partition table failed, kernel still uses old table: Device or resource busy

I needed to umount and rewrite the partition table in order for /dev/mmcblk0p2 to appear.

Partitions

Why don't we boot from NAND?

What's the reason for two partitions? Is it because ext2load was broken? Can we just upgrade u-boot and use one partition?

Is there any need for a swap partition?

--Brian 252 15:22, 8 August 2008 (UTC)

Touch screen calibration

Few days ago there was added calibration for gta02. It doesn't work correctly on my freerunnuer (the mouse pointer doesn't move where I click ant the touchscreen area is about 1/3 smaller then the screen). I tried /etc/pointercal from qtopia and openmoko but it is the same as with parameters from this wiki. Has somebody a tip how to fix this?

--Jakubzeman 07:42, 8 August 2008 (UTC)

I'm using lenny. Oh and if some one wants to see if they can get a debian based kernel / merge / get some more modules from debian / general modules into a kernel for other hardware (such as a rt73 chipset wireless card that would be great :) ) Dbmoodb 08:09, 8 August 2008 (UTC)

Thanks for suggestion. I'll try it (and I'll report if I'm successful or not). --Jakubzeman 08:56, 8 August 2008 (UTC)

Sound

http://tehinterweb.com/freerunner/alsa.state.tgz --Dbmoodb 13:55, 21 August 2008 (UTC) (if it doesn't work for you... try these alsa states or the ones posted below from openmoko.org...)

If the sound card is configured properly but there's no sound coming out of the Freerunner, it most likely helps to restore an appropriate statefile from the tgz above which are also available on the Openmoko svn (/trunk/src/target/audio/om-gta0*).

For simple sound output to the internal stereo speakers, do:

alsactl -f /path/to/statefiles/stereoout.state restore

--Tanuva 12:59, 21 August 2008 (UTC)


debugging fso

The following are taken instructions are taken from lindi on irc.

/etc/init.d/frameworkd stop
/etc/init.d/fso-frameworkd stop
add 'log_level = DEBUG' to '[ogsmd]' in 
/etc/frameworkd.conf
run "frameworkd" and watch the output

--Dbmoodb 08:34, 22 August 2008 (UTC)

Personal tools

Booting

Umount

I remember seeing a umount /media/card command on this page which i don't see anymore. That's needed or you will get

/dev/mmcblk0p1 is mounted; will not make a filesystem here!

Fdisk will also complain

WARNING: rereading partition table failed, kernel still uses old table: Device or resource busy

I needed to umount and rewrite the partition table in order for /dev/mmcblk0p2 to appear.

Partitions

Why don't we boot from NAND?

What's the reason for two partitions? Is it because ext2load was broken? Can we just upgrade u-boot and use one partition?

Is there any need for a swap partition?

--Brian 252 15:22, 8 August 2008 (UTC)

Touch screen calibration

Few days ago there was added calibration for gta02. It doesn't work correctly on my freerunnuer (the mouse pointer doesn't move where I click ant the touchscreen area is about 1/3 smaller then the screen). I tried /etc/pointercal from qtopia and openmoko but it is the same as with parameters from this wiki. Has somebody a tip how to fix this?

--Jakubzeman 07:42, 8 August 2008 (UTC)

I'm using lenny. Oh and if some one wants to see if they can get a debian based kernel / merge / get some more modules from debian / general modules into a kernel for other hardware (such as a rt73 chipset wireless card that would be great :) ) Dbmoodb 08:09, 8 August 2008 (UTC)

Thanks for suggestion. I'll try it (and I'll report if I'm successful or not). --Jakubzeman 08:56, 8 August 2008 (UTC)

Sound

http://tehinterweb.com/freerunner/alsa.state.tgz --Dbmoodb 13:55, 21 August 2008 (UTC) (if it doesn't work for you... try these alsa states or the ones posted below from openmoko.org...)

If the sound card is configured properly but there's no sound coming out of the Freerunner, it most likely helps to restore an appropriate statefile from the tgz above which are also available on the Openmoko svn (/trunk/src/target/audio/om-gta0*).

For simple sound output to the internal stereo speakers, do:

alsactl -f /path/to/statefiles/stereoout.state restore

--Tanuva 12:59, 21 August 2008 (UTC)


debugging fso

The following are taken instructions are taken from lindi on irc.

/etc/init.d/frameworkd stop
/etc/init.d/fso-frameworkd stop
add 'log_level = DEBUG' to '[ogsmd]' in 
/etc/frameworkd.conf
run "frameworkd" and watch the output

--Dbmoodb 08:34, 22 August 2008 (UTC)