Talk:Getting OpenMoko working on host with Xephyr

From Openmoko

(Difference between revisions)
Jump to: navigation, search
Line 40: Line 40:
  
 
--[[User:Miohtama|Miohtama]] 21:50, 2 May 2007 (CEST)
 
--[[User:Miohtama|Miohtama]] 21:50, 2 May 2007 (CEST)
 +
 +
ltrace/sysdeps/linux-gnu had i386 folder, but no i586 folder. I created i586 symlink to i386. Let's see if it works. Ubuntu Feisty Fawn is the build host.
 +
 +
--[[User:Miohtama|Miohtama]] 21:59, 2 May 2007 (CEST)

Revision as of 20:59, 2 May 2007

I get the following error:

OE Build Configuration:
BB_VERSION     = "1.6.7"
OE_REVISION    = "<unknown>"
TARGET_ARCH    = "i586"
TARGET_OS      = "linux"
MACHINE        = "qemux86"
DISTRO         = "openmoko"
DISTRO_VERSION = ".dev-snapshot-20070502"
TARGET_FPU     = ""

NOTE: preferred version 2.12.3 of glib-2.0 not available
...
NOTE: package ltrace-0.4: started
NOTE: package ltrace-0.4-r0: task do_compile: started
ERROR: function do_compile failed
ERROR: log data follows (/media/sda3/dump/workspace/moko/build/tmp/work/i586-linux/ltrace-0.4-r0/temp/log.do_compile.11205)
| /media/sda3/dump/workspace/moko/build/tmp/work/i586-linux/ltrace-0.4-r0/temp/run.do_compile.11205: line 34: INSTALL: command not found
| /media/sda3/dump/workspace/moko/build/tmp/work/i586-linux/ltrace-0.4-r0/temp/run.do_compile.11205: line 34: INSTALL: command not found
| /media/sda3/dump/workspace/moko/build/tmp/work/i586-linux/ltrace-0.4-r0/temp/run.do_compile.11205: line 34: INSTALL: command not found
| /media/sda3/dump/workspace/moko/build/tmp/work/i586-linux/ltrace-0.4-r0/temp/run.do_compile.11205: line 34: INSTALL: command not found
| NOTE: make ARCH=i586 INSTALL_FILE=$(INSTALL) -p -m 0644 INSTALL_PROGRAM=$(INSTALL) -p -m 0755 INSTALL_SCRIPT=$(INSTALL) -p -m 0755 INSTALL_DIR=$(INSTALL) -p -d -m 0755 LDFLAGS=-L/media/sda3/dump/workspace/moko/build/tmp/staging/i586-linux/lib -Wl,-rpath-link,/media/sda3/dump/workspace/moko/build/tmp/staging/i586-linux/lib -Wl,-O1 LIBS=-lsupc++ -liberty -Wl,-Bstatic -lelf -Wl,-Bdynamic ARCH=i586 INSTALL_FILE=$(INSTALL) -p -m 0644 INSTALL_PROGRAM=$(INSTALL) -p -m 0755 INSTALL_SCRIPT=$(INSTALL) -p -m 0755 INSTALL_DIR=$(INSTALL) -p -d -m 0755
| make[1]: Entering directory `/media/sda3/dump/workspace/moko/build/tmp/work/i586-linux/ltrace-0.4-r0/ltrace-0.4'
| make -C sysdeps/linux-gnu
| make[2]: Entering directory `/media/sda3/dump/workspace/moko/build/tmp/work/i586-linux/ltrace-0.4-r0/ltrace-0.4/sysdeps/linux-gnu'
| make[2]: *** No rule to make target `i586/arch.h', needed by `sysdep.h'.  Stop.
| make[2]: Leaving directory `/media/sda3/dump/workspace/moko/build/tmp/work/i586-linux/ltrace-0.4-r0/ltrace-0.4/sysdeps/linux-gnu'
| make[1]: *** [sysdeps/sysdep.o] Error 2
| make[1]: Leaving directory `/media/sda3/dump/workspace/moko/build/tmp/work/i586-linux/ltrace-0.4-r0/ltrace-0.4'
| FATAL: oe_runmake failed
NOTE: Task failed: /media/sda3/dump/workspace/moko/build/tmp/work/i586-linux/ltrace-0.4-r0/temp/log.do_compile.11205
NOTE: package ltrace-0.4-r0: task do_compile: failed
ERROR: TaskFailed event exception, aborting
NOTE: package ltrace-0.4: failed
ERROR: Build of openmoko-devel-image failed
make: *** [openmoko-devel-image] Error 1

--Miohtama 21:50, 2 May 2007 (CEST)

ltrace/sysdeps/linux-gnu had i386 folder, but no i586 folder. I created i586 symlink to i386. Let's see if it works. Ubuntu Feisty Fawn is the build host.

--Miohtama 21:59, 2 May 2007 (CEST)

Personal tools

I get the following error:

OE Build Configuration:
BB_VERSION     = "1.6.7"
OE_REVISION    = "<unknown>"
TARGET_ARCH    = "i586"
TARGET_OS      = "linux"
MACHINE        = "qemux86"
DISTRO         = "openmoko"
DISTRO_VERSION = ".dev-snapshot-20070502"
TARGET_FPU     = ""

NOTE: preferred version 2.12.3 of glib-2.0 not available
...
NOTE: package ltrace-0.4: started
NOTE: package ltrace-0.4-r0: task do_compile: started
ERROR: function do_compile failed
ERROR: log data follows (/media/sda3/dump/workspace/moko/build/tmp/work/i586-linux/ltrace-0.4-r0/temp/log.do_compile.11205)
| /media/sda3/dump/workspace/moko/build/tmp/work/i586-linux/ltrace-0.4-r0/temp/run.do_compile.11205: line 34: INSTALL: command not found
| /media/sda3/dump/workspace/moko/build/tmp/work/i586-linux/ltrace-0.4-r0/temp/run.do_compile.11205: line 34: INSTALL: command not found
| /media/sda3/dump/workspace/moko/build/tmp/work/i586-linux/ltrace-0.4-r0/temp/run.do_compile.11205: line 34: INSTALL: command not found
| /media/sda3/dump/workspace/moko/build/tmp/work/i586-linux/ltrace-0.4-r0/temp/run.do_compile.11205: line 34: INSTALL: command not found
| NOTE: make ARCH=i586 INSTALL_FILE=$(INSTALL) -p -m 0644 INSTALL_PROGRAM=$(INSTALL) -p -m 0755 INSTALL_SCRIPT=$(INSTALL) -p -m 0755 INSTALL_DIR=$(INSTALL) -p -d -m 0755 LDFLAGS=-L/media/sda3/dump/workspace/moko/build/tmp/staging/i586-linux/lib -Wl,-rpath-link,/media/sda3/dump/workspace/moko/build/tmp/staging/i586-linux/lib -Wl,-O1 LIBS=-lsupc++ -liberty -Wl,-Bstatic -lelf -Wl,-Bdynamic ARCH=i586 INSTALL_FILE=$(INSTALL) -p -m 0644 INSTALL_PROGRAM=$(INSTALL) -p -m 0755 INSTALL_SCRIPT=$(INSTALL) -p -m 0755 INSTALL_DIR=$(INSTALL) -p -d -m 0755
| make[1]: Entering directory `/media/sda3/dump/workspace/moko/build/tmp/work/i586-linux/ltrace-0.4-r0/ltrace-0.4'
| make -C sysdeps/linux-gnu
| make[2]: Entering directory `/media/sda3/dump/workspace/moko/build/tmp/work/i586-linux/ltrace-0.4-r0/ltrace-0.4/sysdeps/linux-gnu'
| make[2]: *** No rule to make target `i586/arch.h', needed by `sysdep.h'.  Stop.
| make[2]: Leaving directory `/media/sda3/dump/workspace/moko/build/tmp/work/i586-linux/ltrace-0.4-r0/ltrace-0.4/sysdeps/linux-gnu'
| make[1]: *** [sysdeps/sysdep.o] Error 2
| make[1]: Leaving directory `/media/sda3/dump/workspace/moko/build/tmp/work/i586-linux/ltrace-0.4-r0/ltrace-0.4'
| FATAL: oe_runmake failed
NOTE: Task failed: /media/sda3/dump/workspace/moko/build/tmp/work/i586-linux/ltrace-0.4-r0/temp/log.do_compile.11205
NOTE: package ltrace-0.4-r0: task do_compile: failed
ERROR: TaskFailed event exception, aborting
NOTE: package ltrace-0.4: failed
ERROR: Build of openmoko-devel-image failed
make: *** [openmoko-devel-image] Error 1

--Miohtama 21:50, 2 May 2007 (CEST)

ltrace/sysdeps/linux-gnu had i386 folder, but no i586 folder. I created i586 symlink to i386. Let's see if it works. Ubuntu Feisty Fawn is the build host.

--Miohtama 21:59, 2 May 2007 (CEST)