KnjMokoCalendar

From Openmoko

(Difference between revisions)
Jump to: navigation, search
(+cat)
(catspec)
 
Line 34: Line 34:
 
Help is welcome!
 
Help is welcome!
  
[[Category:Applications]]
+
[[Category:Calendar Applications]]

Latest revision as of 11:10, 19 July 2009

No-screenshot.png knjMokoCalendar

Google calendar client originally written for Om 2008.12


Homepage: http://wordpress.kaspernj.org/?cat=15
Package: knjmokocalendar
Tested on: Om 2008.8


[edit] About the application

knjMokoCalendar is an application for viewing and editing google calendar appointments

At the moment, it can only be used for viewing data stored in the calendar, but it is planned to allow editing later.

[edit] Setup

  • Run the application, and click on the properties button at the bottom of the screen.
  • Type your google calendar logon name and password in to the boxes provided.
  • In the third box, you will need to add the private url to your calendar feed - this can be found in the 'settings' section of google calendar. As this is a long url, it may be best to do it either through screen-sharing, or by pasting the address directly into the sqlite address found in /opt/knjmokocalendar/database/knjmokocalendar.sqlite3 , by using 'sqlite database browser' or similar, on your desktop machine


[edit] Suggestions

knjmokocalendar is under heavy development - please post any suggestions for improvements/bug-fixes here:

Note on installing on SHR :

* added repository
* had to edit /usr/bin/knjmokocalendar because of wrong shebang (#!/bin/bash -> #!/bin/sh)
* had to chmod +x /opt/knjmokocalendar/knjmokocalendar.rb because of -sh: ./knjmokocalendar.rb: Permission denied
* had to install knjrbfw because of ./knjmokocalendar.rb:8:in `require': no such file to load -- knjrbfw/knjdb/libknjdb.rb (LoadError)
* had to install libsqlite3-ruby1.8 because of /usr/lib/ruby/1.8/knjrbfw/knjdb/libknjdb.rb:25:in `connect': /usr/lib/ruby/1.8/knjrbfw/knjdb/libknjdb_sqlite3.rb:16:in `require': no such file to load -- sqlite3 (LoadError)
* had to install libglade2-ruby1.8 because of ./windows/win_calendar.rb:3:in `require': no such file to load -- libglade2 (LoadError)
* seems to be enough with dependencies. Unfortunately : Segmentation fault

Help is welcome!

Personal tools
No-screenshot.png knjMokoCalendar

Google calendar client originally written for Om 2008.12


Homepage: http://wordpress.kaspernj.org/?cat=15
Package: knjmokocalendar
Tested on: Om 2008.8


About the application

knjMokoCalendar is an application for viewing and editing google calendar appointments

At the moment, it can only be used for viewing data stored in the calendar, but it is planned to allow editing later.

Setup

  • Run the application, and click on the properties button at the bottom of the screen.
  • Type your google calendar logon name and password in to the boxes provided.
  • In the third box, you will need to add the private url to your calendar feed - this can be found in the 'settings' section of google calendar. As this is a long url, it may be best to do it either through screen-sharing, or by pasting the address directly into the sqlite address found in /opt/knjmokocalendar/database/knjmokocalendar.sqlite3 , by using 'sqlite database browser' or similar, on your desktop machine


Suggestions

knjmokocalendar is under heavy development - please post any suggestions for improvements/bug-fixes here:

Note on installing on SHR :

* added repository
* had to edit /usr/bin/knjmokocalendar because of wrong shebang (#!/bin/bash -> #!/bin/sh)
* had to chmod +x /opt/knjmokocalendar/knjmokocalendar.rb because of -sh: ./knjmokocalendar.rb: Permission denied
* had to install knjrbfw because of ./knjmokocalendar.rb:8:in `require': no such file to load -- knjrbfw/knjdb/libknjdb.rb (LoadError)
* had to install libsqlite3-ruby1.8 because of /usr/lib/ruby/1.8/knjrbfw/knjdb/libknjdb.rb:25:in `connect': /usr/lib/ruby/1.8/knjrbfw/knjdb/libknjdb_sqlite3.rb:16:in `require': no such file to load -- sqlite3 (LoadError)
* had to install libglade2-ruby1.8 because of ./windows/win_calendar.rb:3:in `require': no such file to load -- libglade2 (LoadError)
* seems to be enough with dependencies. Unfortunately : Segmentation fault

Help is welcome!