FreeRunner unable to work with 3G SIM cards

From Openmoko

(Difference between revisions)
Jump to: navigation, search
(+{{delete}}, +deletion explanation)
(removing most of the content of this page as this problem was fixed long ago with the new GSM firmware)
 
Line 1: Line 1:
{{delete}}
 
{{note|Explanation to deletion: most information concerning problems with some SIM-cards can be deleted now, as this problem has been fixed a long time ago with the new GSM firmware. Deletion proposed by [[User:Marko Knöbl|Marko Knöbl]]}}
 
== FreeRunner SIM compatibility ==
 
 
 
See also: [[FreeRunner_Hardware_Issues#Some_SIMs_Don.27t_Work|FreeRunner Hardware Issues]]
 
See also: [[FreeRunner_Hardware_Issues#Some_SIMs_Don.27t_Work|FreeRunner Hardware Issues]]
  
[[GSM/Flashing]]
+
Formerly there have been some problems with certain SIM cards. ([http://docs.openmoko.org/trac/ticket/666 track ticket]) These issues were fixed with the new GSM firmware. If your FreeRunner has some problems with certain SIM-cards see [[GSM/Flashing]] in order to update the firmware.
 
+
'''So far there were no credible reports of any issues left with any sim cards after upgrading GSM firmware. So, basically, if it works with any old GSM phone, it will work with GTA01 and GTA02 too after firmware upgrade.'''
+
 
+
=== Carrier ===
+
 
+
There is carrier page documented carriers compatibility [[Carriers]]
+
 
+
=== TRAC Ticket 666 ===
+
TRAC ticket  [http://docs.openmoko.org/trac/ticket/666 666] applies to GTA01 (Neo 1973) and to GTA02 (Neo FreeRunner).
+
 
+
== Compatibility table (FreeRunner/GTA02)==
+
 
+
 
+
Please fill out following table .
+
 
+
 
+
{| class="wikitable sortable" style="margin: 0em " cellspacing="0" cellpadding="3" border="1"
+
!Carrier Name!! Error Message !! SIM Card Type!! Country !!Link to picture of SIM card!!Your name!!Did new SIM card solve problem?||Notes
+
|-
+
| CBB || Not working || 2X New 3G SIMs || Denmark || See below. || Dennis N. || I have an older 2G SIM from same carrier that works fine || I have an GTA02E flashed with GSM MOKO11. Have tried with SHR and Android.
+
|-
+
| TDC || Not working || 64K43 || Denmark || no pics || KB || Yes. They sent me a 64K23 card for free and that worked. || The chip on the new card is bigger. It has 4 contact points on each of the 2 columns, instead of 3 on each.
+
|-
+
| CHT || Unable to use GSM  ||Dont' know||  R.O.C Taiwan || no pics ||王孟蒂 Brenda Wang|| ||When I put it on my Neo, it can't dial out
+
|-
+
| AT&T || WORKS  || 71234 G || US || [http://wiki.openmoko.org/wiki/Image:Dave_att_working_sim.jpg image] || Dave || || Calls worked, though it was not used much for calling. SMS worked great. Tested with 2007.2, Qtopia, Qtopia-extended.
+
|-
+
| AT&T || Unable to use GSM  || 71234 G ||  US || no pics || || || 71234 G SIM not working, 71234 O somebody in discuss thread say it could work
+
|-
+
| AT&T || Failed to register  || 71234 D||  US || see below || [[Special:Emailuser/Safire|Safire]] || Switched to T-Mobile || Got strong Signal Bars with 2007.2 image despite "Registering...".  Actually managed to dial and remote phone showed number, but never completed a full call.  Dialer kept crashing.  Pre-paid brand new sim, purchased July 2008
+
|-
+
| AT&T || Failed to register / SIM Not Found  || 3Gc 64205 O 4020 ||  US || no pics || [[Special:Emailuser/vancel35|vancel35]] || Yes || SIM is from the days of Cingular, so it's very old.  Om2007.2 showed "Registering...". Om2008.12 did not acknowledge the SIM.  QT-Extended said "Sim not detected".  Used friend's SIM and was able to place a call immediately. Current is 4020, tested with 4022.
+
|-
+
| AT&T || Fully operational || Cingular branded 3G fireball 73000G 3021 || US || [http://www.ketchuptv.net/neo/cingular.jpg image] || [[Special:Emailuser/nihil|nihil]] || N/A || Added a couple layers of clear tape to add thickness so it would sit more firmly in the carrier. Sporadic failure to register with moko9 GSM firmware, updating to moko11 resolved.
+
|-
+
| Vodafone || cme 13, 32  || some 3G capable||  DE || no pics || [[Special:Emailuser/Fsp|Fsp]] || no || most up-to-date Plan debitel
+
|-
+
| Vodafone || No sim present  || 3G ||  DE || no pics || [[Special:Emailuser/doopa|doopa]] || no || Default sim bought in a vodafone store (1 year old - i.e. 2007/8). Was able to make it work by flashing to the gsm firmware moko10 as per instructions on the wiki.
+
|-
+
| Three (3) (UK & Ireland) || No sim present  || 3G ||  UK || no pics || [[Special:Emailuser/doopa|doopa]] || no || Tried both the English and Irish Three sim cards. Neither worked after upgrade to moko11.
+
|-
+
| T-Mobile || No Error  || 2G SIM ||  US || no pics || Community List || || Pre-paid SIM
+
|-
+
| e-plus || not working  || 3G SIM ||  DE || no pics || Community List || || Plan SIM
+
|-
+
| e-plus (SIMYO) || 2G seems working/3G not || 2G/3G SIM ||  DE || no pics || Community List || || Pre-Paid SIM https://www.simyo.de/de/informieren/umts.html SIMYO has 2 voltage 1.8/3.3v 72K 1.8V #569 J276/2K 3V #568 H276
+
|-
+
| e-plus || working  || 2G SIM ||  DE || no pics || Community List || || Plan SIM
+
|-
+
| O2 || Not certain/Not working  || 3G SIM ||  DE || no pics || Community List || || Plan SIM, CME: 32, (1001710251761MC working)
+
|-
+
| O2 (Alice) || Working  || UMTS/GSM SIM ||  DE || no pics || [[Special:Emailuser/TheGeneral79|TheGeneral79]] || ||
+
|-
+
| O2 || not working || 3G sim || DE || [http://kev.knet.eu/bugs/openmoko/sim-card/not_working_O2.png link] || [[Special:Emailuser/Kevin|Kevin]] || Did not solve. Both simcards (7 month old one and new one) are looking identical. || I would like to help on testing/whatever, feel free to contact me. WORKS NOW with new [http://wiki.openmoko.org/wiki/GSM/Flashing gsm firmware moko10beta2] :)!
+
|-
+
| vodafone(D2 Mannesmann) || working  || 2G SIM ||  DE || no pics || Community List || || Plan SIM
+
|-
+
| Blau SIM  || some working  || 2G/3G SIM ||  DE || no pics || Community List || || 16K 3V #343 H73 (not work)
+
|-
+
| Orange || working  || 2G model J2R ||  FR || no pics || [[Special:Emailuser/pierrebrua|pierrebrua]] || || None
+
|-
+
| Orange || working  || 2G/3G some wokring ||  DE || no pics || Community List || || None
+
|-
+
| Bouygues || working  || 08 series ||  FR || no pics || [[Special:Emailuser/pierrebrua|pierrebrua]] || || Bad sound
+
|-
+
| T-Mobile || Not certain/Not working || unknown ||  DE || no pics || Community List || || None
+
|-
+
| o2 || cme error: 100<br />
+
cme error: 313
+
|| 2G possibly 3g? ||  UK || no pics.. YET. || [[Special:Emailuser/tdobson|tdobson]] || other SIMs work - MTS(RU) Orange(UK) Vodafone(UK) || Prepaid. Feel free to contact me.
+
|-
+
| Orange || working || 3G "USIM" || FR || (see below) || KewlCat || Om2008.8-update (20080827) solved it || Pre-paid SIM
+
|-
+
| Proximus Belgacom Mobile || not working || 2G model 3V || BE || no pics || [[Special:Emailuser/pierrebrua|pierrebrua]] ||  || None
+
|-
+
| BASE || not working || 3G model || BE || no pics || [[Special:Emailuser/Ceupers|Ceupers]] ||  || will be asking for a new SIM card
+
|-
+
| SFR || partially working || 2G model AF and BC || FR || no pics || [[Special:Emailuser/pierrebrua|pierrebrua]] ||  || 50% incoming calls are missed due to lost carrier
+
|-
+
| SFR || not working || 3G model BK || FR || no pics || [[Special:Emailuser/pierrebrua|pierrebrua]] ||  || not detected by the phone
+
|-
+
| SFR || not working || 3G model BC and BK || FR || no pics || [[Special:Emailuser/Drizzt|Drizzt]] ||  || not detected by the phone
+
|-
+
| SFR || not working || 3G model BE and BK || FR || no pics || [[Special:Emailuser/Yoann|Yoann]] || BC model seems working || not detected by the phone
+
|-
+
| IT VODAFONE || not working || 64K || IT || no pics || Six-Blade Knife || Yes || not detected by the phone, changed with 128K and worked
+
|-
+
| MOOV || Working ||  || GA || no pics || Newtek ||  || Not fully tested
+
|-
+
| Mobile Vikings, Belgium || Working ||[[Special:Emailuser/RaGoe|RaGoe]]
+
|}
+
 
+
== User Provided tested SIM pictures ==
+
 
+
[[Image:ATT_3G_71234D_SIM.JPG|left|thumb|200px|AT&T 3G 71234 D]]
+
 
+
Base on community post:
+
 
+
The 71324 is the SKU for the AT&T latest UICC.
+
The 2022 is the Vendor and Version number.
+
 
+
Some cards the vendor numbers are
+
  2 - G&D
+
  3 - Gemalto
+
  4 - Oberthur
+
 
+
Usually user will get CME ERROR 13 (sim failure), rather than CME ERROR 10 (sim not inserted) when 3G SIM not working.
+
 
+
CME ERROR: 32 is Network not allowed, emergency calls only, might because the card not activated.
+
 
+
== The Error ==
+
<pre>
+
Here is the AT command:
+
 
+
root@om-gta02:~# libgsmd-tool -m atcmd
+
libgsm-tool - (C) 2006-2007 by Harald Welte and Openmoko, Inc.
+
This program is Free Software and has ABSOLUTELY NO WARRANTY
+
 
+
AT
+
STR=`AT'
+
RSTR=`OK'
+
AT+CFUN=1
+
STR=`AT+CFUN=1'
+
RSTR=`OK'
+
AT+CPIN?
+
STR=`AT+CPIN?'
+
RSTR=`+CPIN: SIM PIN'
+
AT+CPIN="MyPIN"
+
STR=`AT+CPIN="MyPIN"'
+
RSTR=`OK'
+
AT+CPIN?
+
STR=`AT+CPIN?'
+
RSTR=`+CPIN: SIM PIN'
+
AT+CREG=1
+
STR=`AT+CREG=1'
+
RSTR=`OK'
+
AT+COPS=0
+
STR=`AT+COPS=0'
+
EVENT: Netreg searching for network
+
EVENT: Netreg registration denied
+
cme error: 32
+
RSTR=`+CME ERROR: 32'
+
EVENT: Signal Quality: 31
+
EVENT: Signal Quality: 31
+
</pre>
+
 
+
== Working and not working AT&T card ==
+
 
+
* Some AT&T cards have same vendor/ID number, but different contacts (Josh posted at 2008/8/24), following image shows that card that working (right) and not working (left) one.
+
 
+
[[Image:ATT_simcards_small.jpg]]
+
 
+
 
+
Also, AT&T's new SIM card (left) will work with the Freerunner. It has been tested on om2008. On right is the same non-working SIM as the one shown in the above picture.
+
 
+
[[Image:Sim_cards_new.jpg]]
+
 
+
 
+
== Working and not working CBB card ==
+
 
+
Only difference on these cards seems to be the printing. One works, two doesn't. All 3 cards wirks fine in my HP Voice Messenger, running Windows Mobile.
+
 
+
[[image:SIMs2.jpg]]
+
 
+
== Working SIM pics ==
+
 
+
[[Image:Adam_20080713_working_back.JPG]]
+
 
+
[[Image:KewlCat_20080829_Working_front.png]][[Image:Usim2.png]]
+
[[Image:Working-orange-usim.jpg]]
+
 
+
[[Image:Dave_att_working_sim_small.jpg]]
+
 
+
== Not Working SIM pics ==
+
* AT&T
+
 
+
[[Image:Adam_20080713_back_notworking.JPG]]
+
 
+
* Orange France
+
 
+
[[Image:Jean_20080715_orange_back_notworking.JPG.gif]]
+
 
+
* O2 Germany
+
 
+
[[Image:O2-sim-nonworking-tesa.jpg]]
+
 
+
[[Category:Neo FreeRunner Hardware]]
+
  
 
[[Category:Neo FreeRunner Hardware]]
 
[[Category:Neo FreeRunner Hardware]]

Latest revision as of 21:30, 22 February 2010

See also: FreeRunner Hardware Issues

Formerly there have been some problems with certain SIM cards. (track ticket) These issues were fixed with the new GSM firmware. If your FreeRunner has some problems with certain SIM-cards see GSM/Flashing in order to update the firmware.

Personal tools

See also: FreeRunner Hardware Issues

Formerly there have been some problems with certain SIM cards. (track ticket) These issues were fixed with the new GSM firmware. If your FreeRunner has some problems with certain SIM-cards see GSM/Flashing in order to update the firmware.