Epdfview

From Openmoko

Revision as of 23:42, 14 September 2008 by Kempelen (Talk | contribs)

Jump to: navigation, search
epdfview in QEMU

Descripton

The program epdfview is PDF reader for handhelds using gtk+ and libpoppler.

Build

It can be build using the extra DISTRO_EXTRA_RDEPENDS epdfview in build/conf/local.conf.

There is a binary version available for download here (at your own risk). However when I tried to install it on the new om2008.8 distribution I got:

root@om-gta02:/var/volatile/tmp# opkg install epdfview_0.1.6-r2_armv4t.ipk
Installing epdfview (0.1.6-r2) to root...
Collected errors:
 * ERROR: Cannot satisfy the following dependencies for epdfview:
         *  libglib-2.0-0 (>= 2.16.4) *  libcairo2 (>= 1.6.4) *

Update (Sjors 07:21, 10 August 2008 (UTC)): there is a newer version available here.

cd /tmp
wget http://www.ginguppin.de/files/epdfview_poppler.tar.bz2
wget http://www.angstrom-distribution.org/feeds/2008/ipk/glibc/armv4t/base/libfreetype6_2.3.6-r0_armv4t.ipk
opk install libfreetype6_2.3.6-r0_armv4t.ipk
opkg install libpoppler3_0.8.4-r0_armv4t.ipk
opkg install poppler_0.8.4-r0_armv4t.ipk

opkg install epdfview_0.1.6-r3_armv4t.ipk

Unfortunately the last command still fails:

 * ERROR: Cannot satisfy the following dependencies for libpoppler-glib3:
libglib-2.0-0 (>= 2.16.4) *  gtk+ (>= 2.12.11) *  libcairo2 (>= 1.6.4) *  libpoppler-glib3 (>= 0.8.4) 

The most reecent version of libglib-2.0-dev that I could find for armv4 is 2.16.3-r0. Are these bleading edge files even necessary?

Project Homepage

Personal tools
epdfview in QEMU

Descripton

The program epdfview is PDF reader for handhelds using gtk+ and libpoppler.

Build

It can be build using the extra DISTRO_EXTRA_RDEPENDS epdfview in build/conf/local.conf.

There is a binary version available for download here (at your own risk). However when I tried to install it on the new om2008.8 distribution I got:

root@om-gta02:/var/volatile/tmp# opkg install epdfview_0.1.6-r2_armv4t.ipk
Installing epdfview (0.1.6-r2) to root...
Collected errors:
 * ERROR: Cannot satisfy the following dependencies for epdfview:
         *  libglib-2.0-0 (>= 2.16.4) *  libcairo2 (>= 1.6.4) *

Update (Sjors 07:21, 10 August 2008 (UTC)): there is a newer version available here.

cd /tmp
wget http://www.ginguppin.de/files/epdfview_poppler.tar.bz2
wget http://www.angstrom-distribution.org/feeds/2008/ipk/glibc/armv4t/base/libfreetype6_2.3.6-r0_armv4t.ipk
opk install libfreetype6_2.3.6-r0_armv4t.ipk
opkg install libpoppler3_0.8.4-r0_armv4t.ipk
opkg install poppler_0.8.4-r0_armv4t.ipk

opkg install epdfview_0.1.6-r3_armv4t.ipk

Unfortunately the last command still fails:

 * ERROR: Cannot satisfy the following dependencies for libpoppler-glib3:
libglib-2.0-0 (>= 2.16.4) *  gtk+ (>= 2.12.11) *  libcairo2 (>= 1.6.4) *  libpoppler-glib3 (>= 0.8.4) 

The most reecent version of libglib-2.0-dev that I could find for armv4 is 2.16.3-r0. Are these bleading edge files even necessary?

Project Homepage