Epdfview

From Openmoko

(Difference between revisions)
Jump to: navigation, search
m (Build)
Line 32: Line 32:
 
</pre>
 
</pre>
  
Unfortunately the last command still fails:
+
Unfortunately the last command still fails missing the packages:
 
<pre>
 
<pre>
 
* ERROR: Cannot satisfy the following dependencies for libpoppler-glib3:
 
* ERROR: Cannot satisfy the following dependencies for libpoppler-glib3:
 
libglib-2.0-0 (>= 2.16.4) *  gtk+ (>= 2.12.11) *  libcairo2 (>= 1.6.4) *  libpoppler-glib3 (>= 0.8.4)
 
libglib-2.0-0 (>= 2.16.4) *  gtk+ (>= 2.12.11) *  libcairo2 (>= 1.6.4) *  libpoppler-glib3 (>= 0.8.4)
 +
 +
Please note that missing packages is a subjective problem, depending on previous programs that were/weren't installed
 
</pre>
 
</pre>
  
The most reecent version of libglib-2.0-dev that I could find for armv4 is [http://www.angstrom-distribution.org/feeds/2008/ipk/glibc/armv4t/base/ 2.16.3-r0]. Are these bleading edge files even necessary?
+
The problem can be fixed searching and downloading the missing packages with knjMokoOPKG available [http://www.opkg.org/package_165.html Here]. The next step involves writing:
 +
opkg install http://www.ginguppin.de/files/epdfview_0.1.6-r2_armv4t.ipk
 +
in Terminal to install the PDF Viewer.
 +
 
 +
The most reecent version of libglib-2.0-dev that I could find for armv4 is [http://www.angstrom-distribution.org/feeds/2008/ipk/glibc/armv4t/base/ 2.16.3-r0].  
  
 
<onlyinclude>
 
<onlyinclude>

Revision as of 22:23, 24 March 2009

epdfview in QEMU

Descripton

The program epdfview is PDF reader for handhelds using gtk+ and libpoppler.

Alternatively, evince is in the standard repos, if you don't mind some gnome dependencies - only a few megabytes.

Build

It can be build using the extra DISTRO_EXTRA_RDEPENDS epdfview in build/conf/local.conf.

There is a binary version available for download here (at your own risk). However when I tried to install it on the new om2008.8 distribution I got:

root@om-gta02:/var/volatile/tmp# opkg install epdfview_0.1.6-r2_armv4t.ipk
Installing epdfview (0.1.6-r2) to root...
Collected errors:
* ERROR: Cannot satisfy the following dependencies for epdfview:
*  libglib-2.0-0 (>= 2.16.4) *  libcairo2 (>= 1.6.4) *

Update (Sjors 07:21, 10 August 2008 (UTC)): there is a newer version available here.

cd /tmp
wget http://www.ginguppin.de/files/epdfview_poppler.tar.bz2
wget http://www.angstrom-distribution.org/feeds/2008/ipk/glibc/armv4t/base/libfreetype6_2.3.6-r0.1_armv4t.ipk
opkg install libfreetype6_2.3.6-r0_armv4t.ipk
opkg install libpoppler3_0.8.4-r0_armv4t.ipk
opkg install poppler_0.8.4-r0_armv4t.ipk

opkg install epdfview_0.1.6-r3_armv4t.ipk

Unfortunately the last command still fails missing the packages:

* ERROR: Cannot satisfy the following dependencies for libpoppler-glib3:
libglib-2.0-0 (>= 2.16.4) *  gtk+ (>= 2.12.11) *  libcairo2 (>= 1.6.4) *  libpoppler-glib3 (>= 0.8.4)

Please note that missing packages is a subjective problem, depending on previous programs that were/weren't installed

The problem can be fixed searching and downloading the missing packages with knjMokoOPKG available Here. The next step involves writing: opkg install http://www.ginguppin.de/files/epdfview_0.1.6-r2_armv4t.ipk in Terminal to install the PDF Viewer.

The most reecent version of libglib-2.0-dev that I could find for armv4 is 2.16.3-r0.


Epdf-view.jpeg Epdfview

PDF reader.


Homepage: http://trac.emma-soft.com/epdfview
Package:
Tested on:

Personal tools
epdfview in QEMU

Descripton

The program epdfview is PDF reader for handhelds using gtk+ and libpoppler.

Alternatively, evince is in the standard repos, if you don't mind some gnome dependencies - only a few megabytes.

Build

It can be build using the extra DISTRO_EXTRA_RDEPENDS epdfview in build/conf/local.conf.

There is a binary version available for download here (at your own risk). However when I tried to install it on the new om2008.8 distribution I got:

root@om-gta02:/var/volatile/tmp# opkg install epdfview_0.1.6-r2_armv4t.ipk
Installing epdfview (0.1.6-r2) to root...
Collected errors:
* ERROR: Cannot satisfy the following dependencies for epdfview:
*  libglib-2.0-0 (>= 2.16.4) *  libcairo2 (>= 1.6.4) *

Update (Sjors 07:21, 10 August 2008 (UTC)): there is a newer version available here.

cd /tmp
wget http://www.ginguppin.de/files/epdfview_poppler.tar.bz2
wget http://www.angstrom-distribution.org/feeds/2008/ipk/glibc/armv4t/base/libfreetype6_2.3.6-r0.1_armv4t.ipk
opkg install libfreetype6_2.3.6-r0_armv4t.ipk
opkg install libpoppler3_0.8.4-r0_armv4t.ipk
opkg install poppler_0.8.4-r0_armv4t.ipk

opkg install epdfview_0.1.6-r3_armv4t.ipk

Unfortunately the last command still fails:

* ERROR: Cannot satisfy the following dependencies for libpoppler-glib3:
libglib-2.0-0 (>= 2.16.4) *  gtk+ (>= 2.12.11) *  libcairo2 (>= 1.6.4) *  libpoppler-glib3 (>= 0.8.4)

The most reecent version of libglib-2.0-dev that I could find for armv4 is 2.16.3-r0. Are these bleading edge files even necessary?


Epdf-view.jpeg Epdfview

PDF reader.


Homepage: http://trac.emma-soft.com/epdfview
Package:
Tested on: