ECL

From Openmoko

Revision as of 21:26, 14 May 2010 by Yavannadil (Talk | contribs)

Jump to: navigation, search

Embedded Common Lisp

It's possible to "apt-get install ecl" on Debian on FreeRunner, but as of 23.11.2009 prepackaged ecl fails with "Absurd stack bottom value". This error is due to libgc, which tries to obtain stack bottom from /proc/self/stat and fails. The workaround is to build ecl from source, configuring it with "--enable-boehm=included" and building garbage collector with USE_LIBC_PRIVATES defined. Worked for me with ecl 9.10.2. In QtMoko v22, prepackaged ecl "0.9j (CVS 2008-02-16 11:33)" works, but doesn't understand Unicode.

Personal tools

Embedded Common Lisp

It's possible to "apt-get install ecl" on Debian on FreeRunner, but as of 23.11.2009 prepackaged ecl fails with "Absurd stack bottom value". This error is due to libgc, which tries to obtain stack bottom from /proc/self/stat and fails. The workaround is to build ecl from source, configuring it with "--enable-boehm=included" and building garbage collector with USE_LIBC_PRIVATES defined. Worked for me with ecl 9.10.2. In QtMoko v22, prepackaged ecl "0.9j (CVS 2008-02-16 11:33)" works, but doesn't understand Unicode.