Duke Nukem 3D

From Openmoko

(Difference between revisions)
Jump to: navigation, search
(FAQ/Questions)
Line 50: Line 50:
 
Answer: ask at the proper openmoko.org mailing list
 
Answer: ask at the proper openmoko.org mailing list
  
These answers will be deleted tomorrow. Use the community mailing list or opkg.org to ask.
+
Use the community mailing list or opkg.org to ask.
  
 
[[Category:Gaming]]
 
[[Category:Gaming]]

Revision as of 16:32, 10 March 2009

Legendary First Person Shooter. Rafa shared a simple duke nukem 3d port for Neo which can be played using the accelerometer :)

Note: Game will not run if you don't have accelerometers working properly (check with 'hexdump /dev/input/event2' and 'hexdump /dev/input/event3'. Also make sure PulseAudio isn't running: '/etc/init.d/pulseaudio stop', otherwise it will cause the following error: some people have reported that it will not run resulting in the error 'Unknown multivoc error' even when PulseAudio is not installed - waiting on a workaround. To use game without sound, edit ~/.duke3d/duke3d.cfg and change FXDevice = 0 to FXDevice = 13 under [Sound Setup]

Charles-Henri's version:

The buttons are:

jump            escape
prev weapon     next weapon
open/accept     fire

In menus, click to the left to go back. In y/n menus, click "open" to accept / "escape" to cancel. Saving / loading should work; to save, select a slot, use jump, prev weapon or next weapon to add a dummy name, then press accept.

The Xglamo binary fixes this bug.


Duke3d-openmoko.png Duke Nukem 3D

Legendary First Person Shooter.


Homepage: http://maemo.org/downloads/product/OS2008/duke3d/
Package:
Tested on:



FAQ/Questions

Sergiomtz.losa and Lindi: Don't use the wiki to ask!

Is the game data DFSG free? Answer: The data with the game is the shareware demo level.

I got the following error: ERROR: Cannot satisfy the following dependencies for duke3d: libsdl-ttf Where is that lib? I haven't found it. Answer: ask at the proper openmoko.org mailing list

Use the community mailing list or opkg.org to ask.

Personal tools

Legendary First Person Shooter. Rafa shared a simple duke nukem 3d port for Neo which can be played using the accelerometer :)

Note: Game will not run if you don't have accelerometers working properly (check with 'hexdump /dev/input/event2' and 'hexdump /dev/input/event3'. Also make sure PulseAudio isn't running: '/etc/init.d/pulseaudio stop', otherwise it will cause the following error: some people have reported that it will not run resulting in the error 'Unknown multivoc error' even when PulseAudio is not installed - waiting on a workaround. To use game without sound, edit ~/.duke3d/duke3d.cfg and change FXDevice = 0 to FXDevice = 13 under [Sound Setup]

Charles-Henri's version:

The buttons are:

jump            escape
prev weapon     next weapon
open/accept     fire

In menus, click to the left to go back. In y/n menus, click "open" to accept / "escape" to cancel. Saving / loading should work; to save, select a slot, use jump, prev weapon or next weapon to add a dummy name, then press accept.

The Xglamo binary fixes this bug.


Duke3d-openmoko.png Duke Nukem 3D

Legendary First Person Shooter.


Homepage: http://maemo.org/downloads/product/OS2008/duke3d/
Package:
Tested on:



FAQ/Questions

Sergiomtz.losa and Lindi: Don't use the wiki to ask!

Is the game data DFSG free? Answer: The data with the game is the shareware demo level.

I got the following error: ERROR: Cannot satisfy the following dependencies for duke3d: libsdl-ttf Where is that lib? I haven't found it. Answer: ask at the proper openmoko.org mailing list

These answers will be deleted tomorrow. Use the community mailing list or opkg.org to ask.